help for a noob

Discussion in 'iPhone Tips, Help and Troubleshooting' started by specialops89, Nov 23, 2011.

  1. specialops89 macrumors newbie

    Joined:
    Nov 23, 2011
    #1
    I just bought a 3gs off of ebay a week and a half ago. It was jailbroken and unlocked so that I could use it with T-Mobile. Today I traveled out the country to visit my grandparents for Thanksgiving. Historically, cell signal has been sketchy, so I wasn't surprised when the phone couldn't get a good signal. But I noticed that what signal it got wasn't as good as my previous phone. I also noticed that when it didn't have a cell signal, the wifi wouldn't work either.

    So two questions: is there something I should do that would fix this? And, being that the phone is jailbroken and unlocked, would I get any help from an Apple store or just grief?

    I don't have a data plan. I was just using the phone for wifi. I am a poor college student who doesn't have enough money for his own plan with AT&T, and so I am stuck on a T-Mobile family plan. I saved up money to buy an unlocked iphone so I could use it on T-Mobile without paying for data. Any suggestions for me?

    Thanks in advance.
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Wifi & cell signal are 2 different things, your post said when you don't get signal, then the wifi didn't work either which doesn't make sense at all.

    Do you know if the area where you travel does have T-Mobile service? As I am aware, T-Mobile cost very high for roaming, so you might want to check into that. May be buy a local sim where you are stay and it should work for your phone.
     
  3. specialops89 thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #3
    well, that's what I thought. But when my signal fades, it kills my wifi too. The signal shows as one bar without a carrier name, then says searching, during which time the wifi will come back. Then it will go back to the one bar without the carrier name, and the wifi will die again.

    I have had T-Mobile for years. We have never been charged extra for roaming. And usually if I don't get a T-mobile signal, I'll get some other kind of signal at least faintly. But this is just nothing.

    And like I said, I'm at my grandparent's house. I come out here a lot and have never had trouble before. Granted, this is the first time with the iphone, and my old phone didn't have wifi, so I have no idea how to diagnose this problem.
     
  4. specialops89 thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #4
    Here's some screenshots.
    [​IMG]

    [​IMG]

    And once in a while, I'll get a signal, but it won't last long.
    [​IMG]
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    Can you check to see which firmware & baseband you have on your phone?

    Setting/general/about and look at firmware version & modem firmware.

    You might want to reinstall ultrasn0w from Cydia to see if it fixes the problem.

    For roaming, what I refer to is the data roaming. Since you are using Iphone, there are lot of apps might be required data and that might connect to their server without your notice. So, just be aware of it.
     
  6. specialops89 thread starter macrumors newbie

    Joined:
    Nov 23, 2011
  7. specialops89 thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #7
    Ok. I think I figured out what the problem is. I think connector 7 on the logic board is not making a good connection. I'm currently working on ways to immobilize that connection so it won't come loose. I figured out that the signal only drops after it's been in my pocket for a while banging against my leg. So I finally decided to open up the phone and look around.
     

Share This Page