Help formatting external hard drive

Discussion in 'Mac Basics and Help' started by Kotnirid, Mar 24, 2009.

  1. Kotnirid macrumors newbie

    Joined:
    Mar 24, 2009
    #1
    I received an Acomdata 2Tb external hard drive today from Amazon and plugged it in. Time Machine popped up and I declined to link the hard drive to it. I went into Disk Utility and chose the new hard drive on the left column and went to erase. I chose Mac OS Extended. I named it and hit erase. It started going, and going..... and going... and a half an hour later I knew something was wrong. Disk Utility was not responding and I eventually had to Force Quit. Now I cannot format the hard drive. I starts and then it stops with a disk error. I tried to run the First Aid verify and repair and both stopped after a few seconds with an error. What do I do?
     
  2. oneEG6 macrumors member

    Joined:
    Dec 29, 2008
    #2
    Try partitioning it (one partition is fine) and make sure the setting for GUID is checked. (assuming your on an Intel machine.
     
  3. Kotnirid thread starter macrumors newbie

    Joined:
    Mar 24, 2009
    #3
    Thank you, thank you, thank you!!! It totally worked! Muah!
     
  4. yoak macrumors 65816

    yoak

    Joined:
    Oct 4, 2004
    Location:
    Oslo, Norway
    #4
    The GUID part is important. For some silly reason, default is NOT GUID. I went to the shop thinking my disk was bad, they said it was ok. I read the post here and figured out it.
    Don´t understand why GUID is not default on Intel Macs
     

Share This Page