HELP!! freetype installation

Discussion in 'Mac Apps and Mac App Store' started by Toby Goodbar, Nov 4, 2007.

  1. Toby Goodbar macrumors 6502

    Joined:
    Sep 8, 2006
    #1
    I don't know anything bout scripts. I've been able to figure out how to port utorrent to mac using darwine and x11 following a step-by-step, but it gives me an error seeming to reference a lack of freetype being installed.

    I dloaded free type but have no idea how to install it now. Is there any package installer or otherwise available enabling automatic installation. Or maybe someone has some step by step on how to install?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    This isn't too hard to do. You need the Developer Tools installed. Open a Terminal window, type cd, then a space, then drag the freetype directory to the terminal window. Press Return to execute the command. That done, type the following, pressing Return after each command and waiting until you get a prompt:

    Code:
    ./configure
    make
    sudo make install
    That last one will ask you for your administrator password before it runs. You won't be able to see what you are typing - do not worry, this is normal, and is done for security.
     
  3. Toby Goodbar thread starter macrumors 6502

    Joined:
    Sep 8, 2006
    #3
    Ok, I did it, but after entering "./configure" it says: bad interpreter : no such file or directory

    I tried using same method to install "gnu make" but when doing it, it eventually say "configure : error : no acceptable c compiler found in $path"

    Im not sure exactly how to tell if developer tools are installed but a same titled directiry exists in the apple folder and I know I've installed x11.

    BTW I really appreciate the time & help w/this
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    This won't work unless you've installed the Developer Tools. It looks like you haven't, judging by the error messages you're getting. If you're using Leopard they're on the DVD. If you're on an earlier version of Mac OS X you can download the latest version of the tools from Apple's Developer Connection site. Warning, the file is about 900 MB and will take a while to download.

    You can tell if you have installed the tools by looking for a folder called Developer in the root of your hard drive. It will only be there if the tools are installed.
     
  5. iñaz macrumors newbie

    Joined:
    Feb 10, 2010
    #5
    Ok I' ve done everithing U said, but still I have this problem:
    Thanks for helping




    Macintosh:~ silviasanroma$ cd /Users/silviasanroma/Desktop/Toterias\ y\ curriculums/freetype/freetype-2.3.11/docs/glyphs/
    Macintosh:~/Desktop/Toterias y curriculums/freetype/freetype-2.3.11/docs/glyphs silviasanroma$ . / configure
    -bash: .: /: is a directory
    Macintosh:~/Desktop/Toterias y curriculums/freetype/freetype-2.3.11/docs/glyphs silviasanroma$ make
    make: *** No targets specified and no makefile found. Stop.
    Macintosh:~/Desktop/Toterias y curriculums/freetype/freetype-2.3.11/docs/glyphs silviasanroma$ sudo make install
    Password:
    make: *** No rule to make target `install'. Stop.
    Macintosh:~/Desktop/Toterias y curriculums/freetype/freetype-2.3.11/docs/glyphs silviasanroma$
     
  6. kmaute macrumors 6502

    kmaute

    Joined:
    Oct 5, 2008
    Location:
    USA
    #6
    Do you have spaces in your code? cd to the directory and then enter "./configure". Syntax is critical.
     
  7. n.mcq macrumors newbie

    Joined:
    Jan 11, 2011
    #7
    I am also trying to install Freetype on my Mac. I have been trying to open a file with WineHelper and it says I need to install Freetype

    wine: creating configuration directory '/Users/Nat/.wine'... Wine cannot find the FreeType font library. To enable Wine to use TrueType fonts please install a version of FreeType greater than or equal to 2.0.5.

    When trying to install Freetype in a terminal, it reads

    /Users/Nat/Desktop/freetype-2.3.11/builds/toplevel.mk:43: *** FreeType's build system needs a Make program which supports $(value).

    I read in this thread that I will need the Developer Tools... I do have these, but I tried to open XCode and it says it cannot be used with my version of OS X.
    What is it that I need to be doing to get Freetype working so Wine will cooperate? I've been putting quite a bit of time into this, and I'm rather new to scripts. Help is greatly appreciated. :)
     
  8. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #8
    Open Terminal (in Utilities) and enter

    Code:
    more /usr/X11/lib/pkgconfig/freetype2.pc
    Please post the result, which should tell us what version of freetype is currently on your system.
     
  9. n.mcq macrumors newbie

    Joined:
    Jan 11, 2011
    #9
    Code:
    prefix=/usr/X11
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include
    
    Name: FreeType 2
    Description: A free, high-quality, and portable font engine.
    Version: 9.20.3
    Requires:
    Libs: -L${libdir} -lfreetype
    Libs.private: -lz -Wl,-framework,CoreServices -Wl,-framework,ApplicationServices
    Cflags: -I${includedir}/freetype2 -I${includedir}
    /usr/X11/lib/pkgconfig/freetype2.pc (END) 
    
    That is what came up when I entered your code. I am currently trying to install 2.3.11.
    I went onto the Mac Developer site yesterday and downloaded the proper Xcode for my computer, which has helped, but I am still struggling with the installation.
     
  10. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #10
    What version of OS X do you have? What version of X11? You shouldn't be installing new versions of freetype on your own (unless you really know what you're doing).

    You can install freetype via Macports. You can also pick up a newer version by installing a newer X11 from XQuartz.
     

Share This Page