[HELP] G4 PM will not boot after using Target Disk mode connected Intel iMac.

Discussion in 'PowerPC Macs' started by thefunkymunky, Feb 3, 2006.

  1. thefunkymunky macrumors 65816

    Feb 24, 2005

    We have some new Intel iMacs and have transferred some information from our previous G4 PM (one MDD and one Quicksilver) to the new iMacs. For some reason the G4's will now not boot up and kernal panic on the gray Apple boot screen. This has happened to all the G4's we have in our office. They are running OSX 10.2.8 and the iMacs are running OSX 10.4.4. We can still mount the drives from the G4's using FireWire Target Disk mode.

    I have tried zapping the PRAM etc but they still wont boot. I have also tried running the OSX 10.2 Installer disks to try and reinstall OSX on the G4's but the installer cannot see the drives?

    I tried running the disk utility. It finds the hard drive but wont let me verify/repair permissions (the option is grayed out). It will only let me verify/repair the disk, but it finds no errors. The installer cannot find the disk at all.

    We have more than one hard drive in the G4's and the target disk mode will only mount the system drive, it doesnt see the others, so we cannot retrieve out information. Whats going on. Never had this problem before.

    Anyone have any idea what is wrong. Never had this problem before using the FireWire transfer.


  2. danny_w macrumors 601

    Mar 8, 2005
    Austin, TX
    I heard on the Apple forums that the Intel iMac can't boot from an existing external Mac drive, but that it must be formatted specifically for Intel. I suspect something similar has happened here, in that when you booted into Target Disk mode and mounted it on the Intel iMac, it somehow did something to the formatting of the drive that messed up booting it from the G4. Just a guess, but it sounds plausible. And scary, if this is indeed the case.
  3. disconap macrumors 68000


    Oct 29, 2005
    Portland, OR
    Not to be repetitive here, but I'd suggest FSCK on that drive as well. FSCK will run a lot of repairs, and if any permissions or anything have been changed by the intel mac, FSCK might repair it back to normal....
  4. thefunkymunky thread starter macrumors 65816

    Feb 24, 2005
    Hi, I couldnt run FSCK. The machine kernal panics when trying single user, verbose and safe mode.

    All is fixed now though. Ran TechTool Pro 4 again and te seems to have repaired the drive. All the G4's boot OK now.:cool: :D
  5. bigandy macrumors G3


    Apr 30, 2004
    just a random question, but did apple not say that both machines used in target mode needed to have 10.4.4 if you were doing ppc-intel transfers?

    i'm sure they did, or something very similar..
  6. davedpss macrumors newbie

    Dec 2, 2007
    Same probelm - easier solution (maybe?)

    I had this same problem. Host is an Intel Macbook Pro and the target disk is an ibook G4. G4 harddrive mounted on the Macbook and I copied a few things off and when I tried to reboot the G4 it would not get past a gray screen with the Apple logo on it - no clock or spinning ball. Nothing I tried would work - safe mode, system disks etc.

    I then did the target disk again with the host being a G4 desktop. After mounting the drive on the desktop G4, I shut it down - turned off the ibook - disconnected the cables and restarted the ibook and the desktop. The ibook now booted up as it had before I tried all this.

    My guess was that if the Intel based Mac (running 10.4.11) messed up the formatting on the ibook drive (running 10.3.9) that maybe connecting to another G4 (running 10.3.9) might fix it. Whether it was an Intel issue or a 10.4 to 10.3 issue I don't know but it does work now.

    Hope this helps someone.


Share This Page