Help! Getting crappy Bluetooth sound..

Discussion in 'MacBook Air' started by GenFranco, Mar 19, 2008.

  1. GenFranco macrumors newbie

    Joined:
    Mar 12, 2008
    #1
    Hello all,

    I just purchased a new set of BT speakers from Sharper Image and successfully paired it with my MBA (1.6/80).. and it sounds terrible :(

    I am fussing with the equalizer without much luck. What makes it worse is that I paired the speakers with my Blackberry 8300, and the phone sounds absolutely awesome playing the same mp3 file.. what gives????

    Has anyone notices anything about the sound output of the MBA, especially over BT?? Anything I can do to fix this? Any help would be appreciated, thanks.
     
  2. jont-fu macrumors regular

    Joined:
    Mar 13, 2008
    #2
    Hi, have you configured the BT device as "headphones" and not "headset"? Check this: http://fuzzz.gaulin.ca/2007/10/28/properly-enable-stereo-bluetooth-a2dp-in-leopard/

    Please report if this fixed your problem. I'm planning on getting a BT audio receiver/transmitter (been looking at the Sony HWS-BTA2W, which supports BT 2.0) and would like to hear how others have succeeded in pairing the devices along with opinions in the achieved sound quality.
     
  3. GenFranco thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #3
    Small progress..

    Many thanks for trying to help!! I did check and the KO 500 speakers from Sharper Image are configured as Headphones and not headset correctly. So it might be something else. What is happening is that I am getting music that sounds like it being played in a tunnel, and not that clear. I paired the same speakers to my phone and PC playing the same file and I noticed that the sound was much better and clearer.

    Since then, I have tweaked as much as I could from iTunes, trying the EQ setting for vocal enhance and turning up the Sound Enhancer setting (in Preferences) to Max does help enough that I am not cringing anymore. But I still here a slight echo and feedback. I am going to research more and perhaps try a media player, because I am really hoping it is not my MBA or a general MBA issue. It is only really noticeable when using BT from nice BT speakers, I don't really have much issue with my Plantronics 590 headset.

    Agreed, please report in folks if you have tried your MBA with BT speakers..
     
  4. RobertD63 macrumors 6502

    Joined:
    Feb 17, 2008
    Location:
    A place
    #4
    I am getting the same thing with my Bluetooth headset. The audio is choppy and echos at times. Its on a Mac Mini BTW.
     
  5. Sesshi macrumors G3

    Sesshi

    Joined:
    Jun 3, 2006
    Location:
    One Nation Under Gordon
    #5
    Apple's A2DP support really sucks for some reason. Unless they update the stack, I doubt it'll get any better.
     

Share This Page