Help getting steps more accurate

Discussion in 'Apple Watch Apps' started by DdDr2, Feb 21, 2016.

  1. DdDr2 macrumors member

    Joined:
    Jan 11, 2016
    #1
    my watch has never calculated my steps right. I've contacted Apple, they ran diagnostics, everything came back as fine. I calibrated it. I'm constantly way off on steps. At least a couple thousand.
    I've had the watch since Jan of this year.
    ( I've worn my Fitbit flex and watch on the same wrist for step comparison. ) I regularly get at least 14000 steps a day, and the watch never gets above 10,000.

    I'm wondering if it's cause it refers to my phone's motion tracker. My phone stays pretty still thru the day.
    Is it possible to just turn off my phone tracking my steps and solely refer to the watch ?
     
  2. CobraPA macrumors 6502

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #2
    Steps come from the watch by default, not the phone, it seems, although the phone will combine the two and use whichever one registers them if only one has them.

    What makes you think the Flex is more accurate than what the watch reports?
     
  3. DdDr2 thread starter macrumors member

    Joined:
    Jan 11, 2016
    #3
    Cause I watch on the Fitbit flex app as I walk and my step count corresponds accurately with the reading. But the Apple Watch doesn't. I'll take 100 steps and it will only count 70

    I just want the watch not to refer to the phone at all.
     
  4. zhenya macrumors 603

    zhenya

    Joined:
    Jan 6, 2005
    #4
    I don't think that counting steps is nearly so accurate as that any one device is going to be markedly better than the other, but in any case to turn off the phone's counting go to the Health App and click on the Steps graph. Click on Share Data, then Edit in the upper right of the screen. Under Data Sources you can now set the priority of hardware and software devices and enable or disable them.
     
  5. DdDr2 thread starter macrumors member

    Joined:
    Jan 11, 2016
    #5
    Thanks I'll try that.
    --- Post Merged, Feb 22, 2016 ---
    Mainly I care cause for one, the watch wasn't cheap. I want it to work correctly. Lol. And you do burn calories for walking. So if like my move/calorie ring to be somewhat close to what I'm actually doing
    :)
     
  6. 3568358 macrumors 6502

    Joined:
    Jun 11, 2015
    Location:
    United States
    #6
    On your iPhone go to Settings > Privacy > Motion and Fitness- turn off fitness tracking. All data from movements will come only from Apple Watch. Should fix your issue. I thought about this last night, actually.
     

Share This Page