Help - Getting thrown into shell and can't recover

Discussion in 'Macintosh Computers' started by navylabrat69, Sep 20, 2003.

  1. navylabrat69 macrumors newbie

    Sep 20, 2003
    I've been having trouble with my computer locking up, then wasn't letting me run any programs and finally today it just did it ..

    Yes, I've just found out about Norton and OS X .. oops, wish I would have known earlier.

    I've tried to fsck, seeing that's what all the posts recommend, but that doesn't get me vary far. It's not popping up errors or anything like that ... I've booted from the OS X disk 1 and have run the disk verify, say's there are errors, then the repair and so on and so on .. no luck.

    Tried just to reinstall OS X, but when going through the install, my HD is just not popping up on the destination.

    Help ... I'm much better with a PC because they break more frequently ...


    Frank Riojas
  2. alset macrumors 65816


    Nov 9, 2002
    East Bay, CA
    Do you have another machine that you can use to boot it in target disk mode? Say, an iBook or PB laying around? When you locate a device to use, plug the two together with a FireWire cable. Boot the extra machine, allow it to fully load the Finder. Then boot the troubled machine, holding down the T key (t for target). Trouble should load an FW icon on the display, then load as a removable disk on the extra machine. From here you can run Disk Utility, and perhaps the install.

    Good luck!

  3. Flynnstone macrumors 65816


    Feb 25, 2003
    Cold beer land
    What kind of machine?
    A simple test is to disconnect then reconnect the hard disk IDE cable (both ends) and the power connector.
  4. navylabrat69 thread starter macrumors newbie

    Sep 20, 2003
    It's a 600mHz iMac and don't have another Mac computer ... the rest are PCs ...

    Thanks for the help
  5. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    It sounds as though Finder is broken. I've had this happen a few times on 10.1.x.

    Do you have a prompt with zsh in it?

    I would suggest buying either Drive 10 or Diskwarrior and repairing what fsck can't. Please don't use Norton Disk Doctor on it. You may not have anything left.
  6. navylabrat69 thread starter macrumors newbie

    Sep 20, 2003
    No prompt with zsh ... just sh-2.05a# ... shell ...

    I don't mind formatting provided that I can get some information off the hd ...

    Don't know enough unix commands to establish an ip on the machine so that I can transfer the files to my PC desktop ...don't even know if it will work if I can set an IP ... just an idea ..

    was able to get ver 9 up ... but couldn't do much with ... couldn't do a restore or anything like that ...

    Thanks for all the help ...
  7. bokdol macrumors 6502a


    Jul 23, 2002
    i had the same problem and the only thing that work was reinstalling osx. there seems to be other ways of fixing it but everthing i tried did not work.what i did not try is to fix permissions on the disk.... that might work. but like i said i just reinstalled everything

Share This Page