HELP! Gmail, IMAP and custom "Accounts"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Sounds Good, Nov 20, 2007.

  1. Sounds Good macrumors 68000

    Joined:
    Jul 8, 2007
    #1
    Hi guys,

    I'm looking for some help with Gmail's IMAP and the Accounts feature -- but it might be hard to explain. Here goes...

    I set up 3 separate email accounts of mine to forward the email to my Gmail account. That works great.

    Then, under "Accounts" in the Gmail settings I set up the "Send mail as" feature to this: "When I receive a message sent to one of my addresses: Reply from the same address the message was sent to." This changes the From name and address to match correctly.

    Now... this works fine if I reply to a message from within Gmail on my computer -- BUT -- it does NOT work when I reply to a message from within my iPhone. Instead, it used the default Gmail name and address.

    Anyone know what might be wrong, or (better yet) how to fix it?

    Thanks... :)
     
  2. Sounds Good thread starter macrumors 68000

    Joined:
    Jul 8, 2007
  3. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #3
    there's nothing wrong with your iphone or the settings you've selected. it's just that you can't change the email address you use to reply with - it simply uses the account under which the email was received and you can't change this.

    this may be addressed in a future update from apple, but of course, no one knows for sure...
     
  4. Sounds Good thread starter macrumors 68000

    Joined:
    Jul 8, 2007
    #4
    But Gmail is designed to work exactly this way (see here). And it *does* work exactly this way when done on a computer. So are you saying that it just doesn't work on the iPhone?
     
  5. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #5
    it just doesn't work on the iphone - this setting does not transfer to the iphone, nor is there a way to adjust the email account used to send a reply on the iphone itself. you're out of luck on this one.
     
  6. Sounds Good thread starter macrumors 68000

    Joined:
    Jul 8, 2007
    #6
    Bummer. I really need to use the business address to reply to customers, not the Gmail address. Any work-arounds that you're aware of?
     
  7. michaelhiga macrumors newbie

    Joined:
    Nov 28, 2007
    #7
    This was driving me crazy, too. Thank goodness for forums like these - I couldn't find the answer on the GMail help pages.

    I found this on another forum, so credit goes out to that poster - I'm just wanted to spread the love cuz I saw that this forum didn't have the answer posted yet.

    On your iPhone->Settings->Mail:
    "If you’d like to use a custom “from” address when sending from iPhone (not your Gmail address) — just pop it in the Email Address field (not the authentication fields) and it will use that address instead of your Gmail."

    It works! Enjoy!

    Higgy
     
  8. pittster macrumors regular

    Joined:
    Nov 11, 2007
    Location:
    UK
    #8
    which one is the email address field?
    thanks.
     
  9. michaelhiga macrumors newbie

    Joined:
    Nov 28, 2007
    #9
    Once you've navigated to your Gmail settings, its the 3rd field down, titled "Address", right after "Name".

    Higgy
     
  10. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #10
    i haven't tried this, but it sounds like a good tip. however, it still won't fix the original poster's problem entirely. he has 3 email accounts forwarded to his gmail account, and this fix still doesn't allow him to pick which one of the 3 accounts to reply from on the fly, unless he goes and changes his settings before replying to each message...
     
  11. Sounds Good thread starter macrumors 68000

    Joined:
    Jul 8, 2007
    #11
    Right.
     

Share This Page