Help: Google Chrome and Photoshop CS6 not starting

Discussion in 'Mac Apps and Mac App Store' started by cybersk8er, Mar 16, 2014.

  1. cybersk8er macrumors newbie

    Joined:
    Mar 16, 2014
    #1
    Photoshop launches but freezes when I tried to open file or use the menu. Google chrome sometimes launches, but doesn't connect to internet.
    Firefox and safari works.

    I have tried literally everything.
    I think this started when I downloaded Mavericks and rebooted.

    - I have tried erasing, repairing hard-drive and reinstalling osx mavericks like 4 times
    - tried downgrading back to Mountain Lion using bootable usb
    - tried deleting plist of google chrome and photoshop in the preferences folder
    - tried resetting PRAM

    THE ONLY SOLUTION THAT WORKS IS SAFE BOOT. THE APPS RUN PERFECTLY FINE IN SAFE MODE.

    Dont want to use safe mode because it disables 3rd party fonts, which i need because im gfx designer.

    It doesn't make sense. Please help.:(
     
  2. thekev macrumors 604

    thekev

    Joined:
    Aug 5, 2010
    #2
    If it doesn't happen in safe mode, it's probably not bad memory. May I ask what hardware you're running? I know those both typically switch to discrete graphics on notebooks with discrete graphics. Fortunately both run fine on integrated as long as you don't need to use an external display on a machine that has discrete graphics. The problem with photoshop can also be caused by hard drive issues. They were really bad in the older versions of OSX, back when Leopard and Tiger were common. Now it's not common at all, but it matches the behavior. You can test if the drive is just getting thrashed by hitting preferences --> privacy--> and dragging the boot drive to that. You can revert it later. If you have an external drives plugged in, try unmounting and disconnecting them. Firmware bugs can cause hanging. I also have to ask, the drive isn't nearly full is it?
     
  3. Crusader007, Mar 16, 2014
    Last edited: Mar 16, 2014

    Crusader007 macrumors member

    Joined:
    Dec 17, 2013
    #3
    Chrome does not support 64-bit Java 7. Did you check on that? Find out which Java version is on your machine by typing "java -version" in terminal without quotes.
     
  4. cybersk8er thread starter macrumors newbie

    Joined:
    Mar 16, 2014
    #4
    Processor 2.66 GHz Intel Core i7

    NVIDIA GeForce GT 330M 512 MB

    OS X 10.8.5 (12F45)

    8 GB 1067 MHz DDR3

    500GB harddisk, no it is not full.

    I have erased my hard disk like 4 times lol, and google chrome and photoshop still havnt managed to work.

    ----------

    it says i havnt installed, going to install now

    ----------

    omg thank you!!!!!!!!!!!!!!!

    Are u ****ing kidding me i spent all that time and i didnt have stupid java????????? How can i be so stupid i spent all week trying to fix this!!!!!!! ****

    ----------

    Its fixed photoshop and google chrome =.=, i shuda of went to this forum day 1
     
  5. thekev macrumors 604

    thekev

    Joined:
    Aug 5, 2010
    #5
    Editing this in...

    That's great, because it means it wasn't a hardware issue. When I saw the model I was a little worried.

    Okay the thing about Chrome wasn't a bad point. Regarding photoshop though, go through the checklist I mentioned first. If none of that is working, try gfxcardstatus. Those gpus did have some trouble, and gfxcardstatus can disable discrete graphics. If you're within 3 years of date of purchase, I would suggest taking it into Apple for diagnostics. Otherwise I would ask anyway. If that is the problem, they deny repair, and it's not cost effective to repair, leave discrete graphics disabled. Given that those are pre HD 3000, you might have to switch OpenGL drawing to "simple" if you experience any lag, but it's not that big of a deal.
     
  6. cybersk8er thread starter macrumors newbie

    Joined:
    Mar 16, 2014
    #6
    ok thanks man, im whacking myself in the head of how stupid i can be. why didnt i have java in the first place tho?
     
  7. thekev macrumors 604

    thekev

    Joined:
    Aug 5, 2010
    #7
    It's an easy mistake. I think that is normally handled through system updates or prompts. I don't recall ever having to go out of my way to install it.
     
  8. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #8
    I have Chromium installed, 32-bit only, and it runs fine without java installed.
     

Share This Page