Resolved help: HDD directories? damaged. *SOLVED*

Discussion in 'Mac Basics and Help' started by ratm247, Dec 20, 2011.

  1. ratm247, Dec 20, 2011
    Last edited: Jan 8, 2012

    ratm247 macrumors newbie

    Joined:
    Mar 14, 2009
    #1
    greetings,

    i have a 1tb USB external disk that is attached to a mac mini i use for a server. the other day i came home to find it unmounted. when i mounted it again it had issues.

    i believe the hardware is fine, it seems like the directory is wrecked. it was likely transferring files when it shut down, but its been more difficult to fix than it should be. here are the facts as i can tell so far:

    the disk will mount.
    the root folders and files are visible.
    get info returns an accurate account of space used and available.
    folders appear empty and files won't open. if you try a few times the drive will appear empty.
    disk utility can't repair it because finder can't unmount it.
    when i try to unmount it from a finder window it says its still in use. i must force it to unmount.
    a lsof in terminal reveals that the finder .trashes, and occasionally, mds(spotlight indexing) is using the disk.
    relaunching or kill PID from terminal does not stop them from using those files, nor does restarting computer or remounting drive.
    i ran diskwarrior with the same result as disk utility.
    i ran test disk, and after 2 days of scanning seem to have a log file of bad directories, but it didn't fix anything.
    i ran data recovery 3 and it failed quick scan, and suggested i run a deep scan. deep scan ran for 2.5 hours and claimed to have not inspected even 1 block. i quit then, as i can't wait 2.5+ hours a block for almost 2 billion blocks.

    Most of the data came from the internet so i can recover it in time, however i have home movies i had transferred there temporarily because the drive they were on filled up, and the drive where i had them was not part of my backup scheme.

    I'm fairly confident that the data can be restored. get info returns the correct amounts, and i haven't seen evidence of mechanical trouble.

    could someone suggest some way i could repair the directories, or at the very least recover a few key files?

    also there are a few methods i haven't tried, but they include destructive methods(such as initialize the disk and rebuild the table), and i don't want to resort to them just yet.


    thank you for your time.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    If Data Rescue 3 can't find anything, your chances of recovering anything useful from the drive are near zero in my experience. It's amazingly effective at data recovery. The progress bar on it isn't particularly accurate, so it's possible that it's just not updating regularly.

    Based on your description, though, it sounds an awful lot like bad blocks on the drive--at the least, that would result in the behavior you're describing. In particular, when the drive is first connected, the OS attempts to mount it, and when it finds a broken directory index or partition map, it attempts to repair the problems, and if that fails to mount it read-only for data salvage.

    If it's running into a bad block on that initial data load, the drive will enter its recovery routine, which results in it hanging the I/O bus, and when that happens the OS is locked up as far as access goes until it starts responding again--it's a weakness of the low-level I/O subsystem of OSX.

    One question: If, after first connecting it to the computer, you put your ear on it, what kind of sound is it making? Rhythmic, random-sounding access, or nothing?

    Two things you could try: Get a copy of TechToolPro and see if you have more luck with that than Disk Warrior; it's not great, but it has salvaged a few drives in the past.

    And, install SMARTReporter; it's free, and while the SMART stuff is useless with a USB drive it can also report I/O errors, which will indicate to a degree what's wrong with the drive. (I'm assuming it's USB or FW, not a Franken-Mini eSATA setup; if it's eSATA, I've had sleep-related issues with some eSATA controllers on my own kludged setup.)
     
  3. ratm247 thread starter macrumors newbie

    Joined:
    Mar 14, 2009
    #3
    *solved*

    Thanks for the suggestions. I finally got it to work. heres how....

    after trying all suggestions, i just needed use of the drive, so i tried to erase it so i could try to recover the files after. It would not let me erase it using disk utility, or various terminal commands.

    i booted my macbook into windows 7 to try to format it and realized that I could now read all the files perfectly. I saved all the files i wanted and then tried to use win 7 to format it. it blue screened the first time, then great success. rebooted into lion and formatted again back to hfs+.

    after this experience, the next bit of cash i get is going to set up a UNIX RAID 5 NAS from the remnants of my gaming PC.
     

Share This Page