Help, help, help, internet problems

Discussion in 'iMac' started by xxmarcoxx, Jan 25, 2008.

  1. xxmarcoxx macrumors newbie

    Joined:
    Jan 25, 2008
    #1
    Hey guys just got an imac is my sisters old computer and i think this is where the problems starts, is a 17 in g5, Problem is guys that im not getting an ip address, and when i go to network it says my ethernet is not conected.
    After like 3 hours of renewing and im not exactly sure what else i did, I FINALLY WENT ONLINE!! but today i restart the computer and when it went back on is offline again :(
    Im new to macs so any help will be nice, i know the airport was on, and is was trying to search for network however i dont have a network, thats where i think the problem was i did turn off airport and all that but im still not getting conection, any reason why im not receiveing my ip address automatically?? please help me

    :(
    no one ever had this problems??
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    This may sound stupid, but have you tried a different ethernet cable? I nearly pulled my hair out once with a similar connectivity problem, and it turned out in the end to be a faulty cable. Last thing I would've suspected too as the cable physically appeared to be fine.
     
  3. xxmarcoxx thread starter macrumors newbie

    Joined:
    Jan 25, 2008
    #3
    Hey thanks for the response, as a matter of fact yes i have tried doing that, when i got home yesterday, i had the same problem i dont get an ip address cause my mac says that my ethernet is not conected however my ethernet works with everything else, including my previous computer.
    Today morning my internet is back up, however what is doing is going online after hours of the computer being on? and i just dont understand how is possible.

    SO i get home i turn on the imac and nothing happens, i leave it on 2-3 hours later i get conection.. anyone ever experienced this problems?

     
  4. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #4
    Considering the connection is intermittent, I would suspect you have a bad network card, or a bad ethernet connector on the iMac.

    Just to rule out software though, you want to try backing up all your files, and then doing a reinstall of OS X from scratch. This will ensure that you have a clean install, and drivers or software aren't the problem. If it still acts up, then it probably has to go in for repair.

    Or, if you're out of warranty/Applecare, you could try a wireless connection, assuming this iMac G5 is a 2005 model. Would you happen to have a WiFi router? Does airport work?
     
  5. xxmarcoxx thread starter macrumors newbie

    Joined:
    Jan 25, 2008
    #5
    Hey bud, so over the weekend i took the imac to the apple store, and of course the second they plug it in, it works just fine, so i went ahead and reinstall os X when i got home back from the store, i conected everything and everything STARTED WORKING!!! however i went ahead and did programs update when imac restarted, everything stop working again.
    It was offline all day yesterday, and then i got signal 10+ hours later, well, you guys will think is not an imac problem,but my internet provider problem, well right now i had to conect my dell back again to go online and it works perfectly fine, i just dont get why when i conect my ethernet into the imac it doesnt work, yet at the apple store it works fine, im not sure if my modem and the imac arent getting alone or something i just dont know what to do, i love my imac and i havent even use it and now is just wont work :mad:
     

Share This Page