Help: Home Folder permissions need repair

Discussion in 'macOS' started by Stike, Oct 15, 2011.

  1. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #1
    Hi everyone,

    quick intro: I set up my MacBook Pro with an additional SSD express card as boot drive, leaving my internal HDD as "data drive" with my home folder on it.

    I linked all folders of my home folder to the separate HDD via Aliases, and this works pretty well actually.

    Sadly, during the move and install of Lion, I think I messed with the user permissions of all my (home folder) files.

    Some of them look now like this:

    [​IMG]
    (Lesen = Read, Schreiben = Write)

    Not only am I listed twice here (WTF?) but I also can't remove entries except "staff" with the minus symbol, which is greyed out.

    Is there any app that can help me set those permissions back to a default value? Many documents may have the correct settings but some are just messed up like this.

    Thank you for any help or ideas! :eek:
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    Boot from your recovery partition, open Terminal from the Utilities menu, and type in "resetpassword" without the quotes. This will launch the Password Reset tool. Select the drive, then your user account from the areas at the top, then at the bottom, click the button for "Reset Home Directory Permissions and ACL's". That should deal with any permissions issues within the home folder.

    jW
     
  3. Stike thread starter macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #3
    Hi, thanks a ton!
    Because of your hint (which is a bit overkill actually for my setup and probably not exactly the right medicine) I was able to search online for some more info, and I found this discussion here:

    https://discussions.apple.com/thread/2181549?start=0&tstart=0

    ...which led me to using the terminal with...

    Code:
    sudo chown -R splitmind_de
    chmod -R u+rwX
    ...on the home folder. One test file I was not able to save (overwrite) before, was saving afterwards!

    I think I managed to fix it with this!

    THANK YOU a lot :) :D :apple: :cool:

    PS: Incredible - the one and first and only reply was helpful. Like winning the lottery.
     

Share This Page