iPod touch Help! I can't restore my ipod touch!

kmichael500

macrumors newbie
Original poster
Aug 15, 2011
12
0
Los Angeles, CA
I woke up this morning and found that my iPod Touch 2nd generation was in recovery mode (usb charger pointing at iTunes Symbol). I did what iTunes said and tried to restore it. It started to restore but when it got to the progress bar on the iPod (and itunes said waiting for iPod for about 1 minute) it said "The iPod "iPod" could not be restored. An unknown error occurred (9)."

I have tried everything I could think of. I tried all the steps on the apple website. I made a new user account on my iMac, and disabled all the other software. And it still gave me the same error code at the same time. I tried on another mac...still same error code. I tried with different cables, USB ports, tried plugging my mac direcly into the internet bypassing my router. It still doesn't work!!!

I tried using redsnow to jailbreak it it started and worked for a little while and then it went back recovery mode! I have know idea what to do!!! I have tried EVERYTHING!!!! AHHHHHHH!

Also my iMac and my MacBook are both up to date on snow leopard!

Thanks!

-Michael
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.