HELP! I just got a new mini shipped to me but it won't start up...just keeps beeping.

Discussion in 'Mac mini' started by Baron Aloha, Jul 2, 2010.

  1. Baron Aloha macrumors newbie

    Joined:
    Aug 19, 2009
    #1
    I've tried searching the web and I read the little book that comes with the computer but I cannot find a concrete answer anywhere. Anyone know the reason for this?

    I'm not getting any video or anything. It just keeps beeping every couple of seconds.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Turn it overand twist the base off. Check the ram has not come lose.
     
  3. Baron Aloha thread starter macrumors newbie

    Joined:
    Aug 19, 2009
    #3
    So I opened it up and the ram is completely loose...but it looks like the clip is bent or something. It looks like the silver piece for the clip is supposed to snap onto the thin black piece below it but I have no idea how to get it on. The black piece is visibly bent.

    Anyone know what to do? I think I can get the black piece back in place if I knew what to do. Or should I send it back?

    They are never going to believe me I mean the ram was completely loose...just kind of sitting there.
     
  4. costabunny macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    Weymouth, UK
    #4
    post a photo and we can see what has to be done..
     
  5. Baron Aloha thread starter macrumors newbie

    Joined:
    Aug 19, 2009
    #5
    I would if I had a camera. Upon closer inspection the black sliver was in fact broke so I just removed it completely. It was just plastic. I don't know what it does. After removing it I was able to reinstall the ram and it boots.

    Thank you very much Gav2k for sending me in the right direction.
     

Share This Page