Resolved Help I need to change my MAC address but it won't load

Discussion in 'Jailbreaks and iOS Hacks' started by CoreCreation, Apr 9, 2015.

  1. CoreCreation, Apr 9, 2015
    Last edited: Apr 9, 2015

    CoreCreation macrumors newbie

    Joined:
    Apr 9, 2015
    #1
    i reset my iPads MAC address to 00:00:00:00:00:00 with nvram wifiaddr=00:00:00:00:00:00 because I was evading my dads parental controls however this time I got unluky and changed it to something I can't get out of(00:00:00:00:00:00)
    ... My iPad is running 8.1.2 and jail broken but it is asking me to connect to iTunes because it says it's not setup(similar to when you enter recovery mode[not dfu] except it comes to the hello screen and THEN it shows the "connect to iTunes " screen... I don't have OpenSSH installed but I do have afc2 and was wondering if u could write a script to change the MAC address on boot up or change it with iexplorer etc since I can't reinstall and rejailbreak (since 8.3 is not jailbreakable and they are not signing 8.1.2 anymore....) anyone have any ideas??? Or even edit a file to change the MAC address PLS I already messed up my iPhone I can't lose my iPad too

    Thx


    SOLUTION
    do what the guy said and then download this Link or from this webpage then open up terminal(which you can do by opening spotlight[the magnifying glass in the top right of the mac]), then type the letters cd then press the spacebar once in the terminal and then drag the folder pylon-client from the iPhoneSSH_USB folder into the terminal window anywhere.once it is dropped it a path( which looks something like /Users/username/Downloads/iPhoneSSH_USB/python-client or similar if its downloaded somewhere else on your computer). click enter and then type python tcprelay.py -t 22:2222 &into the same terminal and leave the terminal open. install a ssh client on mac like yummyftp Download Here and then open it and choose sftp and enter;
    server:localhost
    user:root
    password:alpine(unless you changed yours in mobile terminal in which case whatever password you changed it to)
    open up basic settings and chose port 2222
    and then type start the connection(don't edit any other settings)

    a full tutorial can be found here with all the links included http://www.hackthatphone.com/7x/ssh_usb.shtml but ignore step 3.

    then open up another terminal by going to listing at the top and then open in terminal in the yummyftp app and then typing nvram wifiaddr=(desired wifi address here besides 00:00:00:00:00:00 without the brackets) or type nvram -d wifiaddr into the terminal that poped up to change your mac address to a new one or restore to your default mac address

    once you are all done either type command-c or control-c(i forgot which) into both terminals and reboot your iOS device and the connect to iTunes should be gone(along with all your apps so you will have to reinstall your apps[but thats way better than losing your jailbreak since you can just reintall you apps from iCloud]) and you are done :D
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    fortunately, you have afc2 installed so you can access the file system to install OpenSSH

    first, download the OpenSSH package: http://apt.saurik.com//debs/openssh_6.7p1-12_iphoneos-arm.deb

    open your file system browser program (iFunBox, FileExplorer, etc)

    browse to var/root/Media

    If you don't already have a Cydia folder there, make a new folder named "Cydia"

    Open the Cydia folder and create another folder named "AutoInstall" (capitalization matters)

    Open the AutoInstall folder and put the OpenSSH file in there

    Next, reboot your device twice. After the 2nd reboot, OpenSSH should be installed. Some people say a respring is necessary for tweaks/apps to start working after installing this way

    From here, you can try to SSH into your device. I also think the package files will disappear from the AutoInstall folder after it has been installed
     
  3. CoreCreation thread starter macrumors newbie

    Joined:
    Apr 9, 2015
    #3
    THANK YOU i tried it without capitalization and it failed

    i am trying it right now i will brb and post an update thanks...
     
  4. CoreCreation thread starter macrumors newbie

    Joined:
    Apr 9, 2015
    #4
    Omgomgomgomgomgomgomg

    OMGOMGOMGOMGOMG i... ****...damn... omg... O.M.G THANKYOU **** YOU DAMN IT THANK YOU!!!!!!!!!! ****ING THANK YOU!!!!! DAMMIT IT WORKED!!! ADMIN PLEASE BAN ME CUZ IM SO FRIGGING HAPPY :):):):):):):):):):):):):):mad::mad::mad::mad::mad::mad::mad::mad::mad::D:D:D:D damn... sigh... thank you so much i kept trying to ssh after installing(or so i though) opens but i did not capitalize the second capital so it would not install.... THANK YOU SO MUCH... is there a rewards system cuz i will give u all my points!!! thank you :D:):rolleyes::confused::(:eek::):):):):):):D
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    awesome! glad it worked
     

Share This Page