HELP! iBook G4 wont recognize Hard drive!

Discussion in 'PowerPC Macs' started by marclapierre13, Nov 13, 2008.

  1. marclapierre13 macrumors 6502a


    Jul 7, 2005
    Ive searched all over, and cant find a solution.
    I put in a new HD for the 1.2ghz iBook 12", and it wont be recognized by the computer. I tried resetting the Vram/Pram, with no success. I also made sure the hd connector is connected.
    When I hold down "C" to the install disc, it reads the disc, but does not detect the HD. When I do not hold down c, it takes me to a question mark/folder icon.

    I do not think its the new hard disk or connector or logic board, because I have read others having the problem...some say it is the firmware, and that its the OS/Installer disc that has the error...but I have no clue how to fix it.
  2. marclapierre13 thread starter macrumors 6502a


    Jul 7, 2005
  3. jodelli macrumors 65816


    Jan 6, 2008
    Windsor, ON, Canada
    The iBook is limited to parallel ata drives.
    When you boot the OS disk from the C key, if you bring up 'Disk Utility' does it see the drive? You should be able to partition and format from there.
  4. marclapierre13 thread starter macrumors 6502a


    Jul 7, 2005
    No, the disk utility does not recognize the HD.
  5. California macrumors 68040


    Aug 21, 2004
    Did you put the new OS on the drive? I mean, start up from the system disc to install?
  6. kennyli macrumors regular

    Sep 16, 2008
    Hong Kong
    1) Can you G4 still reads the OLD hard drive?

    2) What's the size of your new hard drive? 250MB? 320MB? 500MB?

    It seems to me that if your G4 can still read the old HD, than it may not support your new HD volume. In PC terms, the BIOS is not updated to read the new HD.
  7. r.w.b, Dec 23, 2011
    Last edited: Dec 24, 2011

    r.w.b macrumors newbie

    Sep 25, 2011
    Three years too late, but, for anyone else with the same problem, it's worth checking the other end of the hard drive ribbon cable, which is attached to the lower side of the mainboard, and secured by a piece of sticky tape. It comes undone quite easily, and is easily missed. The tape holds the cable, but the plug is undone. That one happened to me yesterday, on two iBooks. It took a while to spot the problem. Once corrected, the computers worked fine.

Share This Page