Help: iChat saying 'This computer does not support video chats'

Discussion in 'Mac Apps and Mac App Store' started by idrewuk, Jun 10, 2010.

  1. idrewuk macrumors member


    Aug 15, 2008
    Hey all,

    I just logged into iChat and noticed the green icon is only a telephone symbol, not the usual video.

    So I go into Preferences > Audio/Video and the video preview is now a white box with the text, 'This computer does not support video chat'.

    It's a brand new MacBook Pro, iChat has been working fine up to this point. I re-started and still the same message.

    Anybody know what might be wrong? And, how I can fix it?
  2. JediMeister macrumors 68040

    Oct 9, 2008
    Test the iSight camera with other applications like Photo Booth or iMovie. Does it work in either? How about if you go to System Profiler and select USB under Hardware on the left. Does the iSight appear under USB High-Speed bus? If it doesn't work in iChat, Photo Booth, or iMovie, you may want to try an SMC reset.
  3. dsprimal macrumors 6502a


    Mar 27, 2010
    talking about imovie, ichat and photo booth. is the quality of the camera different from each other? for example, on facebook when i post videos direct from the video button on the site, the quality is so crappy (cubes galore all over the play back video). in photo booth the quality seems superb. in skype, my friends have told me the quality of my cam is amazing. and i just checked out imovie for the first time and the quality seems even MORE detailed then photo booth. is this true??
  4. JediMeister macrumors 68040

    Oct 9, 2008
    @dsprimal: I'm not able to tell the difference between a video recorded with iMovie vs. Photo Booth honestly. It doesn't make sense to me that they would save files of different resolutions/quality...
  5. idrewuk thread starter macrumors member


    Aug 15, 2008
    It does work with PhotoBooth just fine. Which makes it all the more confusing.

    Any ideas?
  6. rKunda macrumors 65816


    Jul 14, 2008
    Do you have any other programs that access the camera open? If you do (like photo booth) close it.

    I don't know if that's the case, though.
  7. idrewuk thread starter macrumors member


    Aug 15, 2008
    Nah, nothing else is open... I literally start up my computer, open iChat and the telephone symbol is there, not the camera one. If I open Preferences, it still gives me the same 'not supported' message.

    This is doing my head in! :confused:
  8. JediMeister macrumors 68040

    Oct 9, 2008
    Well, the good news is that it sounds like a software issue with iChat. If it works with Photo Booth there's no need to do that reset I provided instructions for. The next thing you need to isolate if it's an issue with the settings and configuration for iChat or if it's the actual application itself that's gone wonky.

    To test this out you need to create a test user account (on the computer) and re-establish your AIM/Jabber/MobileMe screen name on that other account. If it works in another account its likely the iChat preferences within ~/Library/Preferences/. If it doesn't work in another account you need to reinstall iChat, which I believe is an optional install on your OS X install DVD. Just be sure to remove the from /Applications before you try to reinstall, and also to customize the install so you don't waste time reinstalling something that you already have and is working normally.
  9. Lord Vader macrumors 6502a

    Lord Vader

    Apr 26, 2010
    Death Star
    Open Terminal and paste this:

    defaults write newbwdup 300000

    press enter.
  10. CarlizzleRose macrumors newbie

    Jul 10, 2010
    I have this problem too! If anyone has a solution, I would really like to know.
  11. superzita33 macrumors newbie

    Mar 20, 2011
    Lord Vader...I know this is half a year later, but- thanks for the advice, you rule! working isight :)
  12. zodiakp macrumors newbie

    Oct 14, 2011
    Thank you

    Lord Vader: I know its been long time since some has posted on this topic, but I have been looking for the solution and I just found it. Thanks alot. it worked like charm
  13. georgenx macrumors newbie

    Mar 9, 2008
    Restart with the internet disconnected

    Restart with the internet disconnected. This has resolved my problem a few times. the bug thats in there is to do with a sharing issue.
  14. ndgold macrumors newbie

    Oct 13, 2011
    Lord Vader's Fix Works!

    I had success with using the following in terminal:

    defaults write newbwdup 300000

    I was receiving the following message:

    Attached Files:

Share This Page