HELP...iLiberty+ question...

Discussion in 'Jailbreaks and iOS Hacks' started by MacChinoNyc, Apr 17, 2008.

  1. MacChinoNyc macrumors 6502

    Joined:
    Apr 14, 2008
    #1
    Basically I unlocked/activated/jailbroke my iphone and now want to restore it back to its original state or as close as I can come to it. Long story. Anyone, please tell me the proper steps. Not sure how to do it properly. Thanks.
     
  2. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #2
    The only way to do it is using BootNeuter.

    First make sure you screenlock is set to NEVER!

    On your jailbreaked phone - start installer and:

    Add http://scape-server.org/iphone to the sources in installer.

    Then look under tools for BootNeuter.

    Install BootNeuter.

    Exit installer.

    Click on BootNeuter.

    It will detect your current settings.

    If your phone was 1.1.2 firmware or newer then you need to go back to bootloader 4.6.

    Select the 4.6 bootloader then:

    Make sure that: Neuter, FakeBlank and Unlock are all OFF.

    Then press flash.

    DO NOT INTERUPT THE PROCESS OR YOU WILL BREAK YOUR PHONE.

    DON'T Click on Home or Restore or anything.

    It will take between 5-10 minutes.

    When it has finished exit BootNeuter.

    Connect to iTunes and RESTORE TO 1.1.4.

    set up the phone as NEW. DO not restore from a previous backup!

    Then activate using iTunes if your on an official contract.

    *It may not ask you to set the phone up until after activation and if you don't activate it then it may not ask at all*

    Thats how you do it! Good Luck!
     
  3. MacChinoNyc thread starter macrumors 6502

    Joined:
    Apr 14, 2008
    #3
    Thanks for that, let me tell you what I got though.

    Error:
    The bootloader flash succeeded but the baseband flash failed (Error-3328)

    What now?
     
  4. J.Rich19 macrumors newbie

    Joined:
    Jun 10, 2008
    #4
    BootNeuter Error 3328

    OTB 1.1.2
    Running 1.1.4
    Baseband 04.04.05_G
    AT&T Subscriber

    ZiPhone downgraded my bootloader to 3.9 so i used bootneuter and Flashing the Bootloader worked fine but flashing the baseband failed i got error 3328 http://images.macrumors.com/vb/images/smilies/confused.gif

    What does that mean??

    BTW everything is working fine but i want to restore in itunes is it safe
     
  5. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #5
    You don't need to reflash your bootloader to restore in iTunes.

    Your problem however could be lots of different things including ZiPhone messing up your phone so you can't flash it ever again.

    If it works I would leave it how it is - its still unlocked so don't worry.
     
  6. klueck macrumors newbie

    Joined:
    Jul 16, 2008
    #6
    no unlocking...

    After having run iLiberty+ on a 1.1.4 firmware, my phone does not show the carrier nor does it show edge... (sim is introduced of course).
    I tried so many methods before! And everytime a small step failes. iLiberty+ has worked as a charm - only the last step is really making me sad: where is my network??
    I first restored a "clean" 1.1.4 firmware and then launched iLiberty+. The "Unlock with 3.9FB" is not really clear for me...

    Any help would be welcomed!
    As I am currently traveling and need contact to the outer-world in case of emergency...

    Here's the last part of the log, when I tried to check "Unlock with 3.9FB":
    ....
    2008-07-16 11:31:42 -1000 Fixing YouTube...
    2008-07-16 11:31:42 -1000 Done
    2008-07-16 11:31:42 -1000 Extracting package...
    2008-07-16 11:31:44 -1000 Trying fix for bootloader 3.9...
    2008-07-16 11:31:47 -1000 Looks like previous attempt failed
    2008-07-16 11:31:47 -1000 Now trying to downgrade BL to 3.9FB...
    2008-07-16 11:31:50 -1000 Bootloader downgrade completed
    2008-07-16 11:31:50 -1000 Trying to fix again...
    2008-07-16 11:31:53 -1000 Sorry, we didn't make it :(
    2008-07-16 11:31:58 -1000 Downgrading BL from 4.6 to 3.9FB
    2008-07-16 11:31:58 -1000 ------------------------------
    2008-07-16 11:31:59 -1000 Wrong bootloader version: 3.9_M3S2
    2008-07-16 11:32:00 -1000 Abort in 10 seconds
    2008-07-16 11:32:10 -1000 Extracting package...
    2008-07-16 11:32:12 -1000 Bootloader version: 3.9_M3S2
    2008-07-16 11:32:18 -1000 Baseband version: 04.05.04_G
    2008-07-16 11:32:18 -1000 Unlocking 04.05.04_G (3.9_M3S2)...
    2008-07-16 11:32:21 -1000 Unlock failed.
    2008-07-16 11:32:26 -1000 *** Please report to developers
    2008-07-16 11:32:31 -1000 Finishing up... done
    2008-07-16 11:32:31 -1000 Phase 2 completed
    2008-07-16 11:32:31 -1000


    Cédric

    edit:
    I finally found a solution with "ZiPhoneOSX patched by kIREmK 04.05.04_G [En].app" .
     

Share This Page