Help! I'm so far in the jailbreak process...

Discussion in 'Jailbreaks and iOS Hacks' started by three gee, Dec 5, 2015.

  1. three gee macrumors newbie

    Joined:
    Dec 5, 2015
    #1
    ...and afraid to move forward given the number of hours I've spent!

    Focus Question: How do I get the iphone to stop "searching" and recognize my tmobile network?

    Product Info:
    iphone 3gs
    model # A1303
    serial # 88203UT0EDG
    iOS: 6.1.6 (10B500)
    firmware: 05.16.08
    carrier: TMobile 14.2

    History:
    1. restored through current version of iTunes
    2. inserted TMobile sim
    3. used Redsn0w 09.15b2 to jailbreak (used IPSW iPhone2,1_6.0_10A403_Restore firmware)
    4. followed directions to untether (used p0sixspwn)
    5. installed and ran ultrasn0w to unlock (through Cydia)

    Current Struggle:

    phone recognizes my tmobile sim (in Settings - About) but is stuck "Searching" or "No Network." I have done the steps over and over above...many times with strangely different results and I have FINALLY got the phone back to where it is actually unlocked (recognizes sim as TMobile). I am afraid to move forward for fear of having to redo this all again (although I suspect that may be the case...at least I believe I know the process.

    What was done wrong? Why won't the phone recognize the network with my sim in it?

    Thank you in advance for responding!
     
  2. three gee thread starter macrumors newbie

    Joined:
    Dec 5, 2015
    #2

    UPDATE: 6:27 PM EST

    I found the following fix, but haven't tried it yet. Can anyone vet it for me? I'm not 100% sure what some of the terms mean ("flash"). I'm also concerned about the "upgrade iPad baseband" because Redsn0w gives me a warning that the phone is after 34 weeks and the radio would be bricked. There were a number of people responding that it worked for them, but then I don't know the models or serial numbers of their phones!


    Model: IPHONE 3gs new bootrom

    1) flash IOS 5.1.1. official firmware to your device using iTunes.
    2) Use Redsnow 0.9.14.b1 with official IOS 5.1.1 IPSW (select extras then select manually specify IPSW from the redsnow menu)
    3) choose back on the redsnow menu, put your phone into DFU mode jailbreak the device and choose these options: install cydia, upgrade with iPad baseband continue through the warnings.

    4) once the jailbreak is complete, go to cydia install ultrasnow 2.5.7.
    5) respring
    6) go back into cydia then go to search, find mobile substrate and uninstall it. (this will also uninstall ultrasnow)

    7) go back into cyida for the third time and reinstall the mobile substrate package.

    restart

    9 ) go back into cydia for the fourth time and reinstall ultrasnow.

    10) respring

    10) receive signal

    Something is getting corupted during the baseband install which is causing you to have to reinstall the mobile substrate package and then ultasnow is able to unlock the phone.
     
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    do NOT upgrade to the ipad baseband. you will brick your phone and the cellular functions of it will never work again

    According to your serial number, 88203UT0EDG, your iphone 3gs was manufactured at the 3rd week of 2012. you have the newer bootrom

    are you relying on ultrasn0w to use the iPhone 3GS? ultrasn0w does not support the baseband version 05.16.08
     
  4. three gee thread starter macrumors newbie

    Joined:
    Dec 5, 2015
    #4

    darricksallo, thank you very much for your reply. I now recognize this as a problem. I guess relying on posts (older) on the internet (how I was able to jailbreak the phone) can be an issue when you have an older phone.

    What are your recommendations? Should I downgrade the iOS to 6.1.2 or downgrade the firmware? Does the the firmware relate to the iOS? In other words, if I change one, will I have problems with the other?

    Thank you in advance for your reply.
     
  5. three gee thread starter macrumors newbie

    Joined:
    Dec 5, 2015
    #5

    Or do you recommend using another program other than ultrasn0w? Or is there a version of ultrasn0w that supports 5.16.08?
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    at this point, you will either have to get the iPhone 3GS carrier unlocked (either through the carrier or some online unlocking site) or use some sort of SIM interposer (such as gevey, r sim, etc) that is compatible with your iOS version, modem firmware, and other requirements
     

Share This Page