Help I'm stuck!

Discussion in 'iPhone' started by I.Am.McKinnie, Nov 24, 2010.

  1. I.Am.McKinnie macrumors newbie

    Joined:
    Nov 24, 2010
    #1
    Need some help, has anyone had this before?
    I updated to iOS 4.2 yesterday and when I try to access my iTunes account to download an App for example I get a pop-up:

    "You have not verified your account. Tap OK to review the instructions on how to verify your account".

    I tap ok.

    I get redirected to a "verify your account" page where it tells me "An email has been sent to the address below with a link to verify your account." But underneath it states "Your email address has already been validated successfully, Thanks you" and the option to resend the email is greyed out.

    I found the original verification email and when I click on the link I get "The address has already been verified".

    Totally stuck as I'm going round in circles here!

    I'm new to the forums so any help or advice would be greatly appreciated!
     
  2. Darwin macrumors 65816

    Darwin

    Joined:
    Jun 2, 2003
    Location:
    round the corner
    #2
    Thats a pain, I too am having similar verification issues only this is to do with the Find my iPhone feature which is now free to those with an Apple ID.

    I wouldn't be surprised if the servers in charge of managing this are feeling a little bogged down.

    Does this happen if you make the purchase from iTunes on your computer? (I make the assumption that you where attempting this via your iPhone)
     
  3. I.Am.McKinnie thread starter macrumors newbie

    Joined:
    Nov 24, 2010
    #3
    I've just tried it and I can't even log into the iTunes store on my PC now, exactly the same stuff is happening there too now. What on earth has happened???
     
  4. Mliii macrumors 65816

    Mliii

    Joined:
    Jan 28, 2006
    Location:
    Southern California
    #4
    There are a number of similar posts and threads on MR. You might want to use the SEARCH function here to get a more complete answer.
    As I recall, some people are having success working around this issue by resetting their passwords.
     
  5. smurph macrumors newbie

    smurph

    Joined:
    Mar 21, 2011
    Location:
    Edmonton, Alberta
    #5
    I'm having the exact same issue. I've tried resetting my password and it still doesn't work. I can access the account from everywhere except my iphone. That's where I get the aforementioned error message. Some said to change the email address to something else and then change back. I've done that and it works for the email address that I DON'T want it to be, but not the one I want it to be. I may just have to live with it being something else.
     

Share This Page