HELP! iMac 5K WiFi Issues

Discussion in 'iMac' started by ViRGES, Mar 18, 2015.

  1. ViRGES macrumors newbie

    Joined:
    Mar 18, 2015
    #1
    I recently bought a 5K iMac and been having drops and connection issues with the WiFi. I spoke to Apple and they told me to do the following:


    "Open Network Preneces..
    Turn OFF wifi
    Click Advance under wifi
    REMOVE your wifi network (select the network in the list and select the minus button below)
    Then Save Changes.
    OPEN keychain ACCESS in UTILITY folder..
    Click System on the top left and then click you network on the right and delete it here too.

    Then Turn off the computer.
    RESET your router (even though its working its good to reset so that the computer can get a new ip address lease)"

    I did this and it still keeps disconnecting from the WiFi. It's 100% the machine's fault as I have tried it in two separate locations, both encountering the same issue.

    I just wanted to see if anyone had the same issue before booking in an appointment to go and see Apple in store!

    Cheers,
     
  2. blufrog, Mar 18, 2015
    Last edited: Mar 18, 2015

    blufrog macrumors member

    Joined:
    Dec 19, 2014
    #2
    It's a problem with Yosemite. Make sure you update to 10.10.2 - it solves many issues.

    The steps outlined by Apple also need to be performed - it seems the location database gets corrupted somehow, so deleting it forces it to be rebuilt (do it after updating OSX).

    I had similar issues with my rMBP, but after I updated OSX and did these steps, it fixed the WiFi dropping issue for me.

    I followed the steps here, and it worked great afterwards. Note that changing the packet size may or may not make a difference (it depends upon your wireless router). Resetting the SMC bus appears to be over-kill and not necessary (I didn't do it), as the problem appears to be entirely software-related within OSX.

    http://osxdaily.com/2014/10/25/fix-wi-fi-problems-os-x-yosemite/
     
  3. brerlappin macrumors member

    Joined:
    Oct 14, 2012
    #3
    A friend of mine had this issue and fixed it by changing the security setting from WEP to WPA.

    Hope this works for you.
     
  4. mostin macrumors newbie

    mostin

    Joined:
    Aug 31, 2015
    #4
    Hi, I had the same problem for ages and apple said the same thing, although it didn't make any difference.
    I am with BT and the home hub uses both 2.4ghz and 5ghz. When I disable 2.4 it works fine. This is because the wireless bluetooth mouse works on a similar or same frequency which throws the airport utility out.

    Hope this helps..

    Justin.
     
  5. Marshall73 macrumors 6502a

    Marshall73

    Joined:
    Apr 20, 2015
    #5
    It's nothing to do with the frequency it's BT's crap hub, if you use 2 different SSID for the 2.4 and 5ghz networks it fixes the macs inability to connect.
     

Share This Page