Help! Image Capture not recognizing iPhone on El Capitan

Discussion in 'OS X El Capitan (10.11)' started by StrepMutans, Oct 17, 2015.

  1. StrepMutans macrumors newbie

    Joined:
    Oct 17, 2015
    #1
    Hi all,

    I have just recently upgraded to OSX El Capitan. Everything is running quite OK except with Image Capture which does not recognize my iPhone 6s at all, and therefore stopping me from transferring my iphone photos onto my Mac. It simply reads "no camera or scanner connected".

    Has anyone encountered similar problems? Any help would be greatly appreciated.
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    I think this should be handled by their fresh new yet a little bit infamous photos app.
     
  3. NazgulRR macrumors 6502

    Joined:
    Oct 4, 2010
    #3
    You dont have the iCloud Library turned on on your iPhone 6s, do you?
     
  4. paperstaples macrumors newbie

    Joined:
    Oct 17, 2015
    #4
    Same problem here. Recently updated mbp to El Captain and macos doesnt find any pics/vids on my iphone 5s. Please post here if you find a solution.
     
  5. paperstaples macrumors newbie

    Joined:
    Oct 17, 2015
  6. b.c., Oct 17, 2015
    Last edited: Oct 17, 2015

    b.c. macrumors 6502

    Joined:
    Nov 5, 2008
    #6
    I'm having this same problem too, ever since updating to El Capitan and iOS 9.

    I've been using Image Capture reliably for many years to grab photos off my iPhone and iPad and transfer to Mac. But after upgrading to El Capitan Image Capture would not show any devices connected.

    I managed to get it to work last week after many attempts, I forget how but think I might have finally rebooted the iPhone to get it to work. But now again this week it stopped working. So I rebooted the iPhone and it again Image Capture started working.

    before El Capitan it always just worked. Frustrating, we shouldn't have to reboot the iPhone each time to make this work

    iPhone 5 and iPad Air, iOS 9.02, iMac running 10.11 (using an original Apple brand Lightning cable)

    update:

    p.s. further observation - Image Capture also now seems to sometimes lock up the iPhone after successfully connecting and transferring some photos. I've connected it successfully a couple times today (requiring reboot), but shortly after, if I try again the iPhone seems to hang/crash (requiring another reboot). Never had this kind of problem before El Capitan + iOS 9 - Image Capture used to be solid with this iPhone...
     
  7. StrepMutans thread starter macrumors newbie

    Joined:
    Oct 17, 2015
    #7
    Thank you for the replies. I finally got it to work after rebooting my iPhone and rebooting my Mac, still using the same lightning cable.
     
  8. Freeks macrumors regular

    Joined:
    Jul 2, 2009
    #8
    Damn i have the same problem now as my new iMac came with El Capitan :(

    And it's only my iPhone 6+ that it don't find. My wife's SE works just fine. Booted the phone and changed cable and nothing works. Super annoying as Image Capture have been my go to tool for transferring videos.
     
  9. d-b macrumors member

    Joined:
    Feb 8, 2013
    #9
    Did it keep working for you? For me it works for a moment after a reboot but if I leave the computer running for a couple of days/weeks it breaks again, until next reboot.
     

Share This Page