Help in root

spartak23

macrumors newbie
Original poster
Oct 25, 2004
4
0
I start up holding Command + S and I'm in Single User Mode. I type in:

"
/sbin/fsck/ -y
/sbin/mount -uw /
/sbin/systemstarter
"

Things start loading. It gets to one line "Waiting for Apache web server", it's been on this same line for about 20 minutes, and previous to that I restarted and tried to do it all over. Everytime I get caught up on the "Waiting for Apache web server" though. Please help me out if you know how to bypass this so it all loads correctly in Singlue User Mode.

Regards,
Stas
 

jywv8

macrumors 6502
Jan 11, 2003
322
0
Chicago
I'm not absolutely certain this will work and I haven't tried it myself, but...

In /etc/hostconfig, you can try setting

WEBSERVER=-YES-

to

WEBSERVER=-NO-
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,752
1,218
New Zealand
What exactly are you trying to accomplish by using single user mode? There might be a better way.
 

daveL

macrumors 68020
Jun 18, 2003
2,425
0
Montana
Something doesn't seem right. Why would a Web server be stating up in single user mode?

Well, I poked around a bit and "systemstarter" will ... start up the system! You won't be in single user mode, you'll be in run-level 3.

As nermal said: What are you really trying to do?
 

Similar threads

  • indychris
4
Replies
4
Views
303
  • Jared Strike
2
Replies
2
Views
365
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.