Help! Internal Drive not showing on Desktop!

Discussion in 'macOS' started by judino28, Aug 7, 2008.

  1. judino28 macrumors newbie

    Joined:
    Jul 29, 2008
    #1
    So luckily, this doesn't pertain to my main Computer (Mac Pro) but it is still greatly annoying me as I cannot figure it out!

    So I'm setting up my old PowerMac G4 MDD as a second computer in the house and I went to change the permissions of my 2nd internal drive (it is used only for storing media files) so that only I could see it and not any of the other users. I have successfully done this before in the past but I must have messed up somehow because now it does not show up on the desktop or anywhere else in the finder. It does show up as mounted in disk utility and everything is OK after verification. My startup drive is just fine and shows up (Macintosh HD) but my backup drive (Macintosh HD 2) does not. I've tried various terminal commands that have worked for people with similar problems but none have worked. Most of the commands were for those with external drives.

    Can anyone help suggest anything? I'm stumped as to what to do!
     
  2. ghking macrumors regular

    ghking

    Joined:
    Jul 21, 2007
    #2
    idk if this is the same things but did you try

    Finder > Preferences > Check off "Hard Disks" in the show on desktop section.
     
  3. judino28 thread starter macrumors newbie

    Joined:
    Jul 29, 2008
    #3
    Yes, I've done that. No change. I know I need to do something in Terminal, so that I can change the owner, etc. back to me (even though I didn't think I changed it in the first place, only the privileges of others) I just need the correct command. I've tried various commands but none have worked. Most (if not all) the ones I've tired were for people whose external Firewire or USB drive were not showing, but mine is internal. Not sure if that should make a difference or not.
     
  4. judino28 thread starter macrumors newbie

    Joined:
    Jul 29, 2008
    #4
    Fixed the problem. I don't know why I didn't think of this before. I just signed in as the root user and changed permissions from there. I don't know why I even bothered with all the Terminal stuff.
     

Share This Page