Help - Iomega HD has erased itself !

Discussion in 'Mac Accessories' started by eyelight, May 2, 2007.

  1. eyelight macrumors member

    Joined:
    May 24, 2004
    #1
    Turned on my Powerbook this morning to discover that my Iomerga 320GB Hard Drive now shows up with an icon labeled "No Name" and appears to be completely blank. This Hard drive is only 2 months old and was working fine as of last night. There is about 200GB of stuff on there so I can't figure out what's up.

    Tried running Disk Warrior which has helped me in the past, pulling all my files off a dead LaCie drive, but with the Iomega, Disk Warrior just gives me the following message....

    Directory cannot be rebuilt, the file system is unsupported.
    This disk is not a Macintosh disk.

    and then a little further down....

    File System:MS-DOS/PC

    Any ideas before I start to panic?

    Only recent changes I can think of is that Norton Anti virus did an update yesterday.

    Thanks for any help.
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    Launch Disk Utility- does it see the drive? It might be able to fix the problem.

    Sounds like you never formatted the drive for a Mac therefore, a Mac utility can not fix it.

    Why are you running Norton Anti Virus? Completely unnecessary for a Mac.
     
  3. eyelight thread starter macrumors member

    Joined:
    May 24, 2004
    #3
    Disk Utility sees the drive, but it also sees it as MS/DOS, and it sees it as having 0 files and 298GB available.

    As for Norton Anti Virus.... beats me. Been on the computer for years now. Bought this Powerbook in 2004. I don't subscribe to it but it shows up with an update every now and then.

    Anyway, I think... hope, that all the files are still on the drive, but that the Mac doesn't recognise anything cause of the MS/DOS thing.
    Drive was advertised as being compatable with Macs as well as PCs, and the box it came in has a Mac logo on it, so I never formatted it, and it has worked fine for past two months apart from some problems with iMovie files.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Ahh, if you never formatted it then it'll be using DOS format so that it's compatible with both OSes. That still doesn't explain your problem though.
     
  5. eyelight thread starter macrumors member

    Joined:
    May 24, 2004
    #5
    Yes I should have formatted it. Have found out recently that formatting iot would have eliminated the problems I've had transfering iMovie files to the drive, but otherwise has always been working fine.

    Logically, and someone please correct me here if I'm wrong, there's no way a drive could erase all it's contents by itself overnight.

    Maybe if I can get a friend with a PC to hook it up to their computer I can check the contents, but I can't format the drive now without losing all my files.

    Just tried plugging the drive into my girlfriend's iBook and it is coming up exactly the same as on my Powerbook. Maybe both our computers suddenly don't recognise the MS/DOS formatting. But why????
     
  6. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #6
    I'd try putting it in a windows comp and getting your data out of it. I think that's your only shot.

    Then format when it's back in your comp. In other words, it's a good time to get an external HD for backup.
     

Share This Page