Help iOS5 iCal-Apple has no idea how to fix

Discussion in 'iOS 5 and earlier' started by MoMoMozy, Oct 24, 2011.

  1. MoMoMozy macrumors newbie

    Joined:
    Oct 24, 2011
    #1
    Hi! I have an iPhone 4 and I recently downloaded the new iOS5 and have had major problems that Apple has been unable to resolve since I downloaded the software. The main issues are the on the phone every single one of my calendar events has a duplicate and that the phone iCal is not updating when I make changes to the iCal on my MacBook Pro.

    I've worked with Apple for a couple of days now. They have done lots of tests and things to my phone, including a complete restore, overwriting the iPhone calendar with the iCal calendar, deleting my gmail accounts from my phone, iCloud from the phone, etc, but every time the calendar comes back duplicated and isn't updating with my mac. The iCal on my Mac is correct (no duplicates).

    They don't know what to do and neither do I. Anyone have any ideas? I am running version 10.6.8 on my MacBook Pro and have plenty of free space on it.

    Thank you in advance!
     
  2. sleek881 macrumors regular

    sleek881

    Joined:
    Aug 6, 2010
    Location:
    Sunshine Coast, Australia
    #2
    I had this same thing happen to me on my iphone and ipad, so i removed all syncing in itunes from each devices info tab. On the iphone and iPad go to Settings/iCloud and turn on the calendar and contacts.

    On the Mac in Prefs | iCloud turn on Calendars and contacts there as well.

    So the Calendar syncing to the cloud and the iphone is getting the info from the cloud. Otherwise your iphone is getting info from the cloud and itunes hence the duplicates.
     
  3. Tom G. macrumors 68000

    Tom G.

    Joined:
    Jun 16, 2009
    Location:
    Champaign/Urbana Illinois
    #3
    This was a common problem with MobileMe as well. The solution was basically the same. I'm surprised that Apple did not know of it since they walked me through it on Mobile me.
     
  4. necoandjeff macrumors newbie

    Joined:
    Oct 24, 2011
    #4
    That's correct. If you are syncing your iPhone with iCal on your Mac through iTunes AND syncing your iPhone through iCloud, you're going to get duplicate entries. You need to do two things: 1. As the poster above suggests, turn off the iPhone syncing with iCal through iTunes (click on your device in iTunes, select the Info tab and then uncheck the option to sync your calendar. 2. Doing this, of course, will prevent the iCal on your Mac from keeping up-to-date with changes in your calendar, so the second thing you need to do is go into the application settings for iCal and use the add account function to add your iCloud account. That will keep the iCal on your Mac also syncing with iCloud.

    ----------

    Note that merely turning on sync calendar in the iCloud settings on your Mac, as one poster suggests above, is not enough. You also need to go into iCal on your Mac and add your iCloud account (and probably delete all other accounts to avoid duplication).
     
  5. MoMoMozy thread starter macrumors newbie

    Joined:
    Oct 24, 2011
    #5
    Thank you

    Thank you everyone for your help. I ended up getting help (not from Apple, they didn't know what to do). It involved making a copy of my calendar. I don't remember all the details now, but it is working! Thanks again, everyone!
     

Share This Page