iPhone HELP! iPhone 3GS No Service after Redsn0w jailbreak with ultrasn0w unlock

Discussion in 'Jailbreaks and iOS Hacks' started by CanucksFan15, Jul 10, 2013.

  1. CanucksFan15 macrumors newbie

    Jun 27, 2013
    Vancouver, BC
    I have an iPhone 3GS currently locked to FIDO (subsidiary of Canadian carrier Rogers), new bootrom running iOS 4.1 with baseband (05.13.04). Originally when I received the iPhone it was running 5.0, baseband 6.15.00. I used Redsn0w 0.9.15b3 to restore to 4.1, jailbroke the phone, and then downgraded the baseband to (05.13.04). I then installed ultrasn0w 1.2.8 and inserted another carrier's sim card. The phone gave 1 bar of signal for a second or two, and then switched to "No Service".

    I understand that quite a few people have had this issue and I have read up on possible solutions, but still cannot get the phone to connect to any network.

    I have tried the following in an attempt to resolve the No Service issue:
    1. Reinstall mobile substrate and ultrasn0w within cydia
    2. Completely remove ultrasn0w and install it fresh
    3. Cycle airplane mode on/off
    4. Turn iPhone on/off

    The iPhone is not blacklisted. The model # is MC143C and the serial # is "xx022Gxxxxx" (June 2010 production I believe)

    I also read online about 'flashing the baseband' again. I am not too sure on how I would go about doing this, and I also I read something about it could possibly brick the 3GS?! Don't want to mess the phone up permanently.. Its worth mentioning that I do not have any SHSH blobs saved so I'm limited to iOS 4.1. I hoping to get the phone on an untethered JB and unlocked so I can throw in any sim and go.

    Any assistance or suggestions would be greatly appreciated! Please help, I'm stuck and the phone is essentially useless unless I can figure it out and get it to connect to a network
  2. TriJetHero macrumors 601


    Oct 13, 2010
    Only for 3GS's build after week 28 2011 you can damage the BB chip by flashing 06.15

    If your 3GS is from 2010, you should be ok.

    You can either choose 4.1 with an untethered JB OR
    6.1.3 with a tethered JB as the 3GS can be JB with the limera1n exploit with redsn0w.

    If you downgrade the BB sometimes you need to reflash the iOS so try restoring to 4.1 and see if that works. Use redsn0w to make NO_BB custom IPSW or go to Extras/even/more/restore and follow instructions to preserve your BB at 5.13.04
  3. CanucksFan15, Jul 11, 2013
    Last edited: Jul 11, 2013

    CanucksFan15 thread starter macrumors newbie

    Jun 27, 2013
    Vancouver, BC

    So I went through the steps your provided going to Extras/even more/restore and followed the instructions to preserve the baseband and restore 4.1. Redsn0w said the restore was successful. The iPhone was then stuck in the Recovery loop. I was able to get the phone into DFU mode and then used the "Recovery Fix" option in redsn0w. It went through its process and appeared to jailbreak my phone. When my phone turns on after the jailbreaking process finished, it says "No SIM card installed, Insert a valid SIM with no PIN lock to activate phone". I don't have the original SIM, or any SIM on the carrier FIDO. Also, the back screen of the phone still shows the recovery image (USB with arrow up to iTunes logo). Any idea on how I can get around this no SIM card issue?

    EDIT. Sorry I fixed it! Jailbroke it again with redsn0w and all looks good. Only clicked "install cydia" in redsn0w. Installed ultrasn0w and will try another carrier's SIM card tomorrow (when I have access to one). Only have a nano sim at my house. I will post tomorrow with the results, thanks for your help!
  4. CanucksFan15 thread starter macrumors newbie

    Jun 27, 2013
    Vancouver, BC
    It worked!! Thank you TriJetHero for your help, much appreciated

Share This Page