HELP! iPhone 3GS Upgrade to 5.0.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by milkduds112, May 18, 2012.

  1. milkduds112 macrumors newbie

    Joined:
    May 18, 2012
    #1
    I have iPhone 3GS AT&T running on 3.1.2 (Yes i know old *** firmware rofl, i restore via .shsh blob to do something)
    And now i want to run an iOS 5 untether jb. So i planned to upgrade to 5.0.1. Everytime i go in itunes and try to restore i get the "3194" error and i cant restore. I tried recovery mode/dfu and restoring = doesnt work. I've tired edit the "hosts" in the drivers folder, that did not work either....
    I have no clue what to do and it shouldnt be this difficult....
    Solutions?
    Thanks.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    It is that difficult if you're not doing it right.
    You cant just restore to 5.0.1 like that.
    You will have to create a custom 5.0.1 with redsnow and stitch your shsh blobs to it. Then put your iphone in pwned dfu mode with redsnow and then restore with itunes by selecting your custom 5.0.1 firmware with your stitched blobs.
    Assuming you have shsh blobs for 5.0.1 right?
    Learn and research about the process before you try anything.
    There's plenty of tutorials here:
    http://www.iclarified.com/tutorials/iphone/index.php
     
  3. milkduds112 thread starter macrumors newbie

    Joined:
    May 18, 2012
    #3
    ughhh. dam. no i dont have my shsh blobs for 5.0.1.
    But i can't even restore to 3.1.2 or 3.1.3 .
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Are you sure?
    I figured since you're JB on 3.1.2 cydia would automaticly saved your blobs.
    Run Tinyumbrella to see if you have any available just in case.
    If not the untethered for 5.1.1 should be out within a week or so I believe.
     
  5. milkduds112 thread starter macrumors newbie

    Joined:
    May 18, 2012
    #5
    Yeah . i don't have them.
    But shouldnt i be able to restore to 3.1.2 or 3.1.3
    those arent working either
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    No.
    You can never restore a 3GS with no blobs to any firmware version but the latest one out that apple is signing.
    Those days where you just downloaded any firmware version and shift restored with itunes were over the day the 3GS came out in June of 2009.
    For the iphone 3G you can still do it though with any firmware 3.1.3 and below.
    Not the 3GS though.
     
  7. milkduds112 thread starter macrumors newbie

    Joined:
    May 18, 2012
    #7
    Lol oh wow...Where have i been...
    I previously owned iPod 2nd gen which was the shift and click restore.
    Thank you for your quick responses.
    I've updated and restored to 5.1.1.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Welcome, yes Apple keeps making it hard for us jailbreak people each time with new hardware and software versions.
    Shouldnt be too long according to Pod2G for the 5.1.1 untethered JB.
    You can always try the tethered version now or if you're lucky and have an old bootrom 3GS you can be untethered right now.
    You can use idetector to see if your iphone has the old or new bootrom.
    http://www.iphoneheat.com/2010/06/idetector-check-iphone-3gs-new-old-bootrom/
     

Share This Page