HELP! iPhone 4 No More Cellular Data Connection

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cshen, Apr 29, 2011.

  1. cshen macrumors newbie

    Joined:
    Oct 16, 2008
    #1
    I just updated to 4.3.2 yesterday. Since this afternoon, my phone does not have any cellular data connection, except for wi-fi. I have checked all the settings and everything is correct. I have even tried to restore the settings and restore the phone. But it still stays the same. :(

    Does anyone have the similar problem before? Could this be the hardware problem?

    No "3G" or "E" or "o" icons anymore. This is singaporean network btw.

    [​IMG]

    Appreciate if anyone can help. Thanks.
     
  2. P.K. macrumors newbie

    Joined:
    Apr 29, 2011
    Location:
    Ireland
    #2
    Are your APN entries correct, or your carrier file installed?
    Settings > General > About - what is the value for "Carrier"?

    Might be worth a reset of your network settings.
    Settings > General > Reset > Reset Network Settings
    This will also wipe all stored WiFi entries and their passwords and reboot the phone.
     
  3. cshen thread starter macrumors newbie

    Joined:
    Oct 16, 2008
    #3
    Carrier is Starhub 10.0. The phone was perfectly working before. I've never jailbroke this phone before. I'm still under contract with Starhub.

    I've tried to reset the network setting already. Also reset the phone as well. Nothing is working. :(
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada

Share This Page