Help! iPhone 4S can't connect to home wifi!

moosquared

macrumors regular
Original poster
Nov 10, 2010
216
0
I just got my iPhone 4S today and I've been trying for hours to get it to connect to a wifi. Once I input the password, the indicator sign just spin and spin until the screen went into safe mode. I tried connecting to a neighbour's wifi and it works. I don't know what's wrong with my wifi. All my PC, iPad and other iPhones work fine.

Any suggestion? :confused:
 

moosquared

macrumors regular
Original poster
Nov 10, 2010
216
0
Solved it. :D:D:D Went on apple discussion board and someone had a similar problem. Followed the instruction and it works!
I use a Belkin N Wireless. F5D8236-4.
 

moosquared

macrumors regular
Original poster
Nov 10, 2010
216
0
Tell us what you did? Others could have the same problems as you..
It seems like it's quite a common problem with the new iOS. I just followed the instruction on one of the apple forum, but I didn't do the factory restore.
https://discussions.apple.com/message/16490677#16490677

- Check if you have MAC filtering enabled - if so disable it or add your iPhone MAC address to 'allowed' list in your router.
- Rebooting the router.
- Change the router channel from "auto" to 11.
- On the iPhone: "Forget this network" and attempt to rejoin.
- Reset the iPhone Network configuration (General -> reset -> reset network).
- Rebooted the iPhone 4S. (Also hard reset).
- Connect to an unprotected network to see if your phone connects to a different router.
- Factory restore iOS5. (don't forget to create a backup first).
 

nebo1ss

macrumors 68030
Jun 2, 2010
2,777
1,493
So basically the router had an access control list and your iPhone 4S wasn't on the list.

Sounds reasonable.
He did not say his router had an access control list. This was just a list of things recommended to try by the Apple forum. I have seen problems with some apple devices connecting to a routers and others not so. Often a reboot fixes the problem. Apple is doing something wrong when it comes to wifi network where they have an unusually high number of problems with connections even to their own routers.
 

brockandrew16

macrumors newbie
Jun 7, 2013
1
0
iPhone 4S problem.

So I'm having trouble with my 4S, it isn't letting me even turn the WiFi from "Off' to "On" at all.I took it to my dealer and the lady there said she just powered down the Phone, popped the SIM out, popped it in, and turned it on and it worked after that. Till now. I have done what she said she did with no success. Is there anyone that can help me with this at all? It'd be greatly appreciated!:)
 

MrMacMack

macrumors 6502a
Oct 24, 2012
837
0
This isolated only to your home wi-fi or issue with any wi-fi network?

Check for iOS software update. Reset network settings. Reset the phone itself (hold sleep / wake + home button).
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.