HELP!? iPhone 5 constantly losing Internet connection for a long time?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mister belly, Apr 23, 2013.

  1. mister belly macrumors newbie

    Joined:
    Apr 23, 2013
    #1
    So on Sunday I bought an iPhone from tmobile at a mall. the guy said to wait ten minutes for it to find itself on the network and it never did. so on Monday I went back to a different tmobile store because it was closer and this guy said they forgot to change the sim number. he fixes it, tells me Internet connection can take awhile until I can use it but i can still text and vall. An hour later it's working perfectly, and wow! it's super fast. I restore backup on iTunes to transfer over things from my iPod to my iPhone and connection wouldn't work at all. I gave it all night and this morning it refused to connect and I got so fed up and just resetted everything. went to school, and towards the end the Internet connection was working flawlessly. hallelujah! except it only worked for an hour and lost Internet connection. I can still text and call. iMessage doesn't work either. I go home look up to see what could possibly be wrong with my new iPhone and I just don't know :(
    I was using it with wifi for awhile, and then switched back to cellular and I had Internet connection for 15 minutes before it refused to work again.
    my friend with an at&t iPhone 5 works said hers never had any problems. I forgot to mention I updated my iPhone to iOS 6.1.3 the day I got it.
    what should I do? go back to tmobile, maybe go to apple?
     
  2. dictoresno macrumors 601

    dictoresno

    Joined:
    Apr 30, 2012
    Location:
    NJ
    #2
    call t-mobile. sounds like theres some kind of issue regarding the way your SIM was programmed or provisioned. since everything works fine on wifi and it appears only cellular data is giving you the issue, its likely something on their end with your account. i would do that first.
     

Share This Page