Help!!! iPhone Bricked After Using Redsn0w!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by petey2428, Jun 21, 2009.

  1. petey2428 macrumors newbie

    Joined:
    Jun 20, 2009
    #1
    Hey guys. My iPhone was an unlocked and jailbreaked 2g with 1.1.3 firmware. I updated it to OS 3.0 on iTunes. Then I used redsn0w to jailbreak/unlock it. everything seemed fine till the "rebooting your iphone" step, but then I realized that I didn't put it in the DFU mode correctly. Then everything worked out fine until the "setting baseband" part. It's supposed to take up to 2 mins, but mine wasn't finished even after 4 hours, so I forced reset it. Then I tried to restore the firmware on itunes, but I got the "iphone cannot be restored error (23)" message. Now my iPhone is permanently in a recover mode I think. The screen only shows either an apple sign or a USB cable plugging into iTunes sign. I've looked everywhere trying to fix this, but none worked out. I tried using iBrick, tried downgrading it to firmware 2.0, 2.1, 2.2, 1.0, 1.1.3, pretty much everything, and now I'm clueless on what to do. Please help me, right now I don't even have a phone! THANK YOU IN ADVANCE!!
     
  2. iTzChasE macrumors 6502

    iTzChasE

    Joined:
    Dec 31, 2008
    #2
    lol

    I have no clue. Hope you find a way to fix it.
     
  3. helavaboi macrumors newbie

    Joined:
    May 4, 2008
    #3
    i have the same problem....i'm with t-mobile but i restored my phone on itunes just cant seem to unlock /jailbreak it... so now my phone only shows the cable plug in to itunes and emergency calls.....for some weird reason i can still receive calls and call out.....but cannot access anything else on the phone.....

    how did u unlock the phone.... i have a 2generation 8G
     
  4. FunkyTang macrumors regular

    Joined:
    Sep 16, 2008
  5. petey2428 thread starter macrumors newbie

    Joined:
    Jun 20, 2009
  6. kenv202 macrumors newbie

    Joined:
    Jun 19, 2009
    #7
    1. Search and locate the restore file for ur phone model (it's in itune somehwere..search for the keyword "ipsw" ) File name is like "iPhone1,2_3.0_7A341_Restore.ipsw" <---3g model

    2. Run redsn0w and pick that firmware , it should say ok and you can now JB it just follow the on-screen instruction..

    PS: Vista user might experience difficulty..go XP or mac

    good Luck, that should get u out of the emergency lock , also since u unlocked b4, you dont have to for 3.0, just need to JB

    i hope this helps
     
  7. petey2428 thread starter macrumors newbie

    Joined:
    Jun 20, 2009
    #8
    thank you for the responses guy. i really appreciate it.

    My iPhone isn't on the emergency screen. It alternates between the apple logo and the plug into the computer logo. I tried using redsnow to jailbreak it but then I got stuck on the disk-with-an-arrow-pointing-on-it screen on my iphone. After that my iphone just resetted itself, and nothing was fixed.

    does anyone know what i can do?

    thanks!
     
  8. Ratpack1961 macrumors member

    Joined:
    Apr 7, 2006
    #9
    Your phone is in recovery mode. In iTunes, press option while selecting restore and select the firmware you want to restore too. Or you can simply just press restore and it will automatically download 3.0 to the phone. Then you can jailbreak.
     
  9. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #10
    Yes, you need to get a clean restore in iTunes to 3.0 by getting it into DFU mode. Watch this video and do what it shows you:
    http://www.youtube.com/watch?v=ofpinyGlQ8I. iTunes will restore it to a clean 3.0 install.

    Then run RedSn0w again. At the point where it tells you to plug the phone in and switch it off, but BEFORE the screen where it gives you the timed instructions for DFU, plug it in and get it into DFU mode again. If you do that correctly, then on the "3 step" screen next, it will recognise the phone immediately. If it doesn't, and still runs the 3 second / 10 second / 30 second timers, you're not in DFU.

    After it says Finished, the iPhone still actually has quite a lot to do. Go and have a beer while it does it.
     
  10. petey2428 thread starter macrumors newbie

    Joined:
    Jun 20, 2009
    #11
    thanks for the responses guys. i really appreciate it.

    The only problem is that I cannot get a clean restore to 3.0 in iTunes, even in DFU mode. I tried pretty much everything (****-restore, restore in recovery mode, restore using different firmwares, etc), but I still got the same error 23 on itunes. Anyone has a clue what can I do? thanks in advance!
     
  11. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #12
    Next thing is to try it on a different computer, if you can.
     

Share This Page