HELP - iPhone Error 6!

Discussion in 'iPhone' started by Pixellated, Jul 29, 2008.

  1. Pixellated macrumors 65816

    Joined:
    Apr 1, 2008
    #1
    Hi all, I have a first gen iPhone on 2.0 and when i tried to restore it today, it said (about 25% of the way through) 'Error 6'

    I have rebooted, i have reinstalled iTunes... Everything.
     
  2. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #3
    The things i looked and found on there didn't work.
     
  3. Yossarian macrumors member

    Joined:
    Apr 3, 2005
    #4
    I fixed a similar problem by clearing some HD space on my machine, it was less an 1GB free and freeing up another couple of GB made it go through.
     
  4. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #5
    Hi, i tried clearing the HD up but wiith 17GB free but it still doesn't work. Thanks for all your help :)
     
  5. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #6
    put it into dfu mode

    Step 1. Turn off your iPhone.

    Step 2. Hold down the power and home button.

    Step 3. When you see the Apple logo, release the power button but continue holding the home button down.

    Step 4. Open iTunes and wait for it to tell you that its in restore mode.

    then restore
     
  6. TonyMil macrumors member

    Joined:
    Jul 21, 2008
    #7
    I wound up switcing USB ports as well as removing the SIM card when I had that problem. Hope you don't have to go that far.
     
  7. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #8
    Thanks a lot guys, trying it now with the sim removed. Is this a common problem? if this doesn't work should i take it to apple?
     
  8. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #9
    Ok, the sim removed and it didn't work, i booked an appointment at the genius bar tomorrow and will report back on how i do. :)
     
  9. TonyMil macrumors member

    Joined:
    Jul 21, 2008
  10. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
  11. Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #12
    OK Guys, i fixed it in the genius bar, the fix was a new iPhone 3G for free :D:p
     
  12. TonyMil macrumors member

    Joined:
    Jul 21, 2008
  13. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
  14. cph macrumors newbie

    Joined:
    Apr 19, 2008
    #15
    What? They gave your a new iPhone 3G to replace your iPhone Edge? Wow...

    Wish I had done what you did and went to Apple Store.

    I had the same err#6 as you. All I did was repeating the (unplug USB cable, plug in again, iTunes detects the phone in restore mode, iTunes tries to restore the phone) process. After a few iterations the restore process went through all the way.

    I have done this 2 times since the 2.0 roll-out. The first time was to update to the new 2.0 firmware. The 2nd time was just for the hell of it. Both times I had to repeat the above procedure many times before the restore succeeded.

    I think now I'm gonna try to restore again and see if I can get a new 3G iPhone out of it:)
     
  15. Pixellated, Jul 31, 2008
    Last edited: Jan 24, 2012

    Pixellated thread starter macrumors 65816

    Joined:
    Apr 1, 2008
    #16
    Good luck, always look for young apple reps, and talk to them as if you know what you're saying :D
    Apple Store FTW! :D
     

Share This Page