Discussion in 'Mac Apps and Mac App Store' started by biohazard6969, Mar 9, 2005.

  1. biohazard6969 macrumors 6502a


    Feb 23, 2005
    toronto canada
    ok, i had to reinstall iphoto, and now it opened fine, but all my pics are gone, so i went to my pictures folder and tryed to click/drag iphoto library back into iphoto but it wouldn't work. it just said "the following files could not be imported (they may be an unrecognized file type or the files may not contain valid data" then in a lits it names the iphoto library file. i don't know wat to do, i tried doing tit with individual pics from the iphoto library and i got hte same message, but with PDF files, that weren't orriginally in iphoto it worked fine.....i don't know wat to do
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Try making iPhoto rebuild your library. You do this by closing it, and then re-opening it while holding command (the apple key), option (or alt) and shift at the same time.
  3. yOyOYoo macrumors 6502a


    Feb 13, 2005
    same thing happened to me. I lost all of my directories and folders in iPhoto.

    I had to use a program called iphoto extractor pro to extract all of my photos.

    Then I had to reorganize everything.

    It was quite a hassle and i still don't know why iphoto decided to lose all of my photos. I just got my new PB 1 month ago!!!
  4. alex_ant macrumors 68020


    Feb 5, 2002
    All up in your bidness
    You shouldn't have done that (dragging the iPhoto library into iPhoto). That may have seriously messed things up. What you should have done is held down option+apple while starting iPhoto. iPhoto will then ask you which library you want to use and you can tell it. Try this... hopefully it will work, however you may have duplicates of all your photos as a result of what you shouldn't have done.

    Don't blame yourself though - iPhoto is unfortunately the crappiest iApp by far, and it's iPhoto's fault.

Share This Page