Help! Ipod won't mount but is recognised by System Profiler

Discussion in 'iPod' started by sunlikeblood, Jul 24, 2005.

  1. sunlikeblood macrumors newbie

    Feb 8, 2004
    I dropped my 3G iPod the other day (from a small height on to carpet, nothing too nasty) but now it won't mount when slotted into the dock or via direct firewire cable connection. I can see that it is attached in System Profiler, including the name I have given the disk, but there is no mount point listed which I think is the problem.

    I have tried everything I can think of to get it to mount including the following:

    Using Disk Utility to mount/unmount and verify or repair disk -

    Repairing disk for “James's iPOD”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid extent entry
    Volume check failed.

    Error: The underlying task reported failure on exit (-9972)

    Repair attempted on 1 volume
    0 HFS volumes repaired
    1 volume could not be repaired

    DiskWarrior 3.0 failed to rebuild the disk

    Tried hard reset, iPod's scan disk was fine (though it keeps going back to it and rescanning often).

    Tried booting into disk mode, again it doesn't mount in the Finder or iTunes though it is recognised by the System Profiler. Power is getting through fine.

    Tried several of the diagnostic tests accessed by pressing Previus Next and Select when the Apple logo comes up - appears to be fine.

    My next step is to do a restore using the iPod updater. It recognises an iPod is attached but only gives the option to restore, not update. I am hoping I can at least mount the iPod once though to retrieve some files I had stored on there before erasing the disk completely, which I am hoping will fix the problem.

    Any other ideas??
  2. taeclee99 macrumors 6502a


    Jun 4, 2002
    Anywhere but here
  3. mj_1903 macrumors 6502a


    Feb 3, 2003
    Sydney, Australia
    Is the iPod mounted in /Volumes/? I have had drives refuse to mount but I have been able to copy files out that way. If it isn't then your only option is to restore the iPod which should return all functionality.
  4. sunlikeblood thread starter macrumors newbie

    Feb 8, 2004
    Thanks, I have that app already but didn't think to try it. Trying it now!
  5. sunlikeblood thread starter macrumors newbie

    Feb 8, 2004
    Not sure what you mean by this part, where do I find that? I'm actually a total novice when it comes to anything involving Terminal or programming languages.
  6. sunlikeblood thread starter macrumors newbie

    Feb 8, 2004
  7. Sedulous macrumors 68020


    Dec 10, 2002
    I think with all the advice already given, if your iPod still won't cooperate, then iPod restore is the next best step.
  8. sunlikeblood thread starter macrumors newbie

    Feb 8, 2004

    I've successfully recovered the files I needed with Data Rescue X, now I will do a restore on the iPod and hopefully everything will be fine again. Thanks to everyone who posted suggestions!
  9. sphereboy macrumors 6502


    May 10, 2002
    My 4G iPod [click wheel] also doesn't get recognized when using the Firewire cable. It works fine with the USB cable but that's not what i want.

    I've done it all:
    Reset & Restart
    Reset, Restore, Restart
    Turn On/Off
    Disconnect, Turn On/Off, Restart, Reset, Restore

    Nothing seems to work.
    I wonder why some of us are having this issue.
    Any new suggestions?
  10. G5Unit macrumors 68020


    Apr 3, 2005
    I'm calling the cops
    This has happend to me before only it was with a first gen. I just used the updater and it was fine.

Share This Page