Help - iTunes and browsers won't play video

Discussion in 'Mac Basics and Help' started by Keefaholic72, Feb 22, 2013.

  1. Keefaholic72 macrumors newbie

    Joined:
    Feb 22, 2013
    #1
    I am running a Macbook Pro 13" icore 7 with mountain lion 10.8.2 and iTunes plays audio only on mp4s and Safari and Firefox won't play videos. Youtube shows the adverts and then stops playing the main video even though it continues to load the video. I have done several clean installs from the restore mode and then migrated my user files to the new install. Quicktime plays all videos in the iTunes library perfectly. Is this a user preferences, cache, or OS X system problem?
    Latest flash player is installed.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Something messed up in the installment of the flash player in your Mac. So follow these steps to reset the Flash Player;

    1. Download the Flash Player Uninstaller and delete the flash Player bits.

    2. Reboot.

    3. Download the latest Flash player.

    4. After the Flash player is installed immediately go to System preferences->Flash Player, Storage mini-tab and delete all the flash savings.

    5. Test Flash videos now and hope these steps helped.

    6. Download thee Free Safari Extension Click to flash and AddBlock (for both Safi & Firefox.

    Now this video not playing at all in iTunes is strange! Did you install any Quicktime third party tools?
     
  3. Keefaholic72 thread starter macrumors newbie

    Joined:
    Feb 22, 2013
    #3
    Interestingly.....

    I loaded the OS X 10.8.2, All the user data, and all the programs, as existed on the 13" Macbook, onto a external drive and then powered up my 15" macbook from that external drive. Everything (all symptoms were gone) went great. I then used the external drive to run the 13" and all symptoms were still present.
    Took the 13" back to best buy. geek squad suspects the video card and is sending it out for diagnostics and repair. One thing I wish I had tried though, is during all my fussing with the 13" I never zapped the pram. It makes me wonder if that could have had an effect. Seems interesting that Quicktime played all the mp4s fine and not itunes.
     

Share This Page