HELP...iTunes and iPhoto not cooperating after HD update...

Discussion in 'Mac Apps and Mac App Store' started by williambhadley, Oct 29, 2010.

  1. williambhadley macrumors newbie

    Joined:
    Oct 29, 2010
    #1
    I put in a 500 GB Seagate Momentus XT HD in my 2010 15" MBP 2.66 GHz i7. I have read conflicting reports about it's effectiveness on both Macs and PCs; however I decided to try it. Overall, I have not had any major issues. Install was painless, including formatting and backup from TM.

    Now, last night and today, I have tried to use (1) iTunes and (2) iPhoto without the results I was seeking.

    1) iTunes does not seem to even want to open correctly. It sits empty with my music tab selected. It seems more like it has frozen than anything else. All my music files are where they were before, so that hasn't changed. I have made sure it is pointing to the correct folder, which it is. I have also tried importing the library, and creating a new library all together. It runs through all the artist folders acting like it is importing them or the artwork, but then nothing ever shows up. Neither option works. When I try to navigate through iTunes, it does not happen. My apps and ringtones do not appear either, which is why I think it has something to do with locating my files, or a hiccup when displaying the lists. I tried Option-click to get my library, and that didn't work. I also deleted and reinstalled iTunes with no success.

    2) iPhoto is telling me I do not have sufficient disk space to import any more photos. I was trying to drag 1 picture into iPhoto. I have about 446 GB free, so that should not be a problem.

    2 Questions:
    - With these libraries, do they in any way associate a serial number or any other identifying factor to particular HDs? i.e., even though everything has been moved to a new HD, does it still look for the old one even if they have the same name, "Macintosh HD"?

    -Should I try to reformat the new HD, and start from scratch...this time attaching my old HD and selectively bringing over files instead of doing the TM backup?


    ****I know the easiest thing to do would be to put my old HD back in, but I want to avoid that for now****
     
  2. williambhadley thread starter macrumors newbie

    Joined:
    Oct 29, 2010
    #2
    Problem Solved...

    Apparently I had not yet run software updates after reinstalling OS X with the new HD. I was able to go through the updates, and then everything worked out just fine.
     

Share This Page