Help! iTunes and permissions errors after installing second HD

Discussion in 'MacBook Pro' started by Blanz, Jun 16, 2012.

  1. Blanz macrumors member

    Joined:
    Jan 10, 2008
    #1
    I just installed an SSD in my mid-2010 MBP in the optical drive bay. I wanted to set it up such that the OS and the applications were on the SSD, while all my "stuff" was on the HD already installed. Everything went smoothly, mac os cloned well, i got my preferences back by going to accounts and selecting my home folder in my old HD. I deleted the folders that weren't called "users" in the old HD so that it couldn't boot (although they are still in the recycle bin)

    (I followed this guide exactly in installing:
    http://lifehacker.com/5541774/how-to-install-a-solid+state-drive-in-your-macbook)
    (also, I put the SSD in the main HD bay and the old HD in the optical bay.)

    Well, after doing all that, I tried opening iTunes, and got an error stating "You do not have enough access privileges for this operation" in reference to it automatically connecting to the itunes store. I learned that I couldn't download anything in iTuens nor could I try to activate or deactivate the computer. (I got the error "The required directory was not found or has a permissions error"). I tried repairing disk permissions in the new SSD and mucking around with files, but that only resulted in iTunes ALSO not being able to recognize any songs (itunes looks as if it was a new computer). weak.

    Anyone have any idea what is going on or what could be wrong? To me it seemed like a made a clone of my old HD, so i don't see whats causing the issue
     
  2. Blanz thread starter macrumors member

    Joined:
    Jan 10, 2008
    #2
    as much as I don't want to be annoying and double post, I know that if it falls off the first page it will never get answered.

    I know someone has got to know what to do in this situation. My old HD is probably a lot like an external hard drive to most people, have you ever had problems with permissions on that?
     

Share This Page