Help - I've lost left click!

Discussion in 'OS X Yosemite (10.10)' started by spiritlevel, Feb 9, 2015.

  1. spiritlevel macrumors 6502

    Joined:
    Nov 5, 2007
    #1
    Was working in illustrator, dragging out a box, then when I let go, my mouse didn't. No matter what I did it kept on dragging the box. Ended up having to hit and hold the power button to shut down.

    When I started up again, I had no left click on my mouse at all and I have not been able to get it back

    It's not my mouse - it's same with both Logitech mouse and Magic mouse.

    I have tried restarting in safe mode - still same problem

    I have tried resetting pRam - still same...

    Working to a tight deadline and I'm desperate! Any ideas?

    Thanks
     
  2. spiritlevel thread starter macrumors 6502

    Joined:
    Nov 5, 2007
    #2
    Never mind - managed to fix it

    Got my trackpad out and the click worked on that. Once I had clicked on that, my mouse worked again.
     
  3. Sirious macrumors 65816

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #3
    Definitely a strange issue and you did everything I would have suggested. Glad you got it working again :)
     

Share This Page