Help Jailbreaking and Restoring

Discussion in 'iPod touch Hacks' started by Patrick7121, May 7, 2011.

  1. Patrick7121, May 7, 2011
    Last edited: May 7, 2011

    Patrick7121 macrumors newbie

    Joined:
    Mar 16, 2011
    #1
    My jailbroken 4g ipod touch is currently on 4.2.1 firmware and I would like to get it too 4.3.3 firmware. Whenever I try to download and update the firmware with itunes it says the firmware won't work for the requested device or something like that. I also tried restoring but the same error pops up for that. I have the lastest version of Itunes so that isn't a problem. :confused:
    I can't seem to download anything on cydia because for some reason the original sources won't work and if I try to add any there are a bunch of errors.
    I am trying to upgrade because I read that upgrading may solve that problem.:rolleyes:

    Any ideas what to do?

    Thanks in advance. :D
     
  2. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
  3. DrEnalg macrumors regular

    Joined:
    Apr 26, 2011
    Location:
    East Bay, CA
    #3
    I found that the hosts file was the problem with me as well, I had this very same issue when trying to restore my 3G Touch.

    It took some trial and error but essentially I found that (possibly due to an OSX automatic update, IDK) there were several IP addresses added to the hosts file that were corrupting it. I erased a couple of them and then made sure there were '#' symbols before the ones that remained - with the final IP address, of course, being the Saurik server.
     
  4. Patrick7121 thread starter macrumors newbie

    Joined:
    Mar 16, 2011
    #4
    Thanks

    :D IT WORKED!
    I can't thank you guys enough. :)
     

Share This Page