Help, Jailbreaking my iPod failed

Discussion in 'iPod touch' started by Kirstylx, Apr 26, 2009.

  1. Kirstylx macrumors newbie

    Joined:
    Apr 26, 2009
    #1
    I tried to jailbreak my ipod touch with quickpwn following a video on youtube. I held shift and pressed restore and chose the file. After it had finsihed I tried with quickpwn and it kept freezing so i decided to give up jailbreaking and just use it with it's normal settings, but it won't restore with itunes :( I only got the ipod touch yesterday and it was for my birthday, can anyone help please?
    It shows : 'The iPod could not be restored. An unknown error occured (1611)'
     
  2. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #2
    I've said this over and over. DO NOT jailbreak. You only get a bunch of poorly designed themes (designed by color-blind or just plain blind people) and applying those themes drains battery like crazy. And a truckload of poorly designed apps. And a few gems you might use once or twice.

    Anyways, try to force the iPod into DFU mode. And then plug it into iTunes for the restore.
     

Share This Page