Help! Kernel Panic on boot after w3690 install on 4,1 to 5,1 2009 Mac Pro

Discussion in 'Mac Pro' started by vbt101, Mar 28, 2013.

  1. vbt101 macrumors newbie

    Joined:
    Mar 28, 2013
    #1
    Hi all -

    I've seen a small number of people post up about issues like this, and of those that I found, no one ever posted back with their solution (if they even found one). Basically, I upgraded my 2009 single 2.66 quad core CPU to a w3690, and I am getting a kernel panic on boot (after the chime, but still on the apple logo screen). I am running OSX 10.7, and had no issues upgrading from 4,1 to 5,1 with the firmware utility.

    Potentially useful info:

    Stuff I HAVE tried:
    - Different sets of RAM (I have one set of 1066 3x1GB and another of 1333 3x16GB, both verified working with the original processor). Same KP issue.
    - Re-installing the w3690 (I thought maybe it was overheating, despite my extremely meticulous cleaning & AS5 application). Same KP issue.
    - Cmd + Option + P + R. Same issue.
    - Cmd + Option + N + V. Same issue.
    - Booting without keyboard and mouse connected (only peripheral is the monitor). Same issue.
    - Booting from Snow Leopard Install DVD (only one that I have). No luck. DVD spins for a while, and after waiting a while *everything basically ends up halting. No KP in this case. Just sits on Apple logo screen.
    - Boot in Single User Mode. Was able to get to a prompt one time before system halted. As soon as I tried mounting the the disk, I got a kernel panic. I don't have a log of it, but it was slightly different than the one I normally get; it references a different Kext. IIRC, it was one of the IO*Family kexts.
    - Switching in the old processor to make sure everything else is still working. Everything works. Using it to write this post.

    Stuff I have NOT tried:
    - Removing the NVidia GT120 entirely; it's the only PCIe card in the machine. Nothing else is connected, except a usb keyboard and mouse.
    - I just realized it now, but this machine was running base 10.7 install (fresh install I guess), and has not been updated. I went through all of the system updates just now, and am up to 10.7.5. Not sure if any of the OS updates could help my issue with the new processor in it. The updates were mostly Java related, and one combined OSX update; nothing firmware related. EDIT: Tried installing the w3690 after the update, and now I simply get stuck at the white apple logo boot screen rather than getting a kernel panic.
    - Fresh install snow leopard retail (again, only cd i have), and try again.

    Any further suggestions? Is this CPU bad? Is there anything I can definitely rule out? Is it at all possible that this is still software or firmware based?

    Thanks in advance!
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    I have no expertise on this, but just a couple of thoughts.

    I'd test the CPU in another machine if possible, to rule out or confirm a bad processor.

    If you bought it on Ebay or some other non-retail boxed method, I'd check to see if it's an engineering sample. Although there is only one stepping for the retail CPUs, an engineering sample could be anything.
     
  3. vbt101 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #3
    I'm going to try calling local repair shops to see if anyone as a test rig for it.

    I purchased the processor from eBay, allegedly tested to be working. As far as an engineering sample, the processor doesn't indicate "ES", Confidential, or have any unusual markings on it that would indicate that is a sample; should it?
     
  4. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #4
    I don't know how to identify them. You might check this page.
     
  5. vbt101 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #5

    Thanks for posting that. Based on what's in that article, I'm 99% sure this is not an engineering sample. I called what appeared to be the most technical computer repair companies near me, and was not able to find anyone who could test this processor. You think something like that would be a little easier to come by in D.C.
     
  6. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #6
    You might want to post your problem to this thread. Much smarter people than I are watching that thread.
     
  7. vbt101 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #7
    bump! anyone have any insight on the original post? if not, im probably going to send the processor back tomorrow. (booo!)
     
  8. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #8
    Might want to try a w3680 (3.33Ghz) since thats the highest (AFAIK) Ghz chip apple uses. Is it stamped SLBW2 on the chip?
     
  9. vbt101 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #9
    Yep, it is stamped SLBW2 -- that's a good thing, right?
     
  10. xav8tor macrumors 6502a

    Joined:
    Mar 30, 2011
    #10
    The 3690 runs fine in a 4.1 flashed to 5.1. Been running one for months now. Booted right up and is properly identified. Seems to run closer to 3.6 than 3.46 with most of my usual apps, even with multiple cores in use. I must have gotten a good one.
     
  11. vbt101 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #11
    PROBLEM SOLVED! It was just a faulty processor. Got a replacement and put that one in...no issues. I think the fact that I could not get a Win7 install DVD to fully boot without getting a BSOD with the same machine check error codes I was getting on the mac side was a dead giveaway that it was the hardware. I didn't want to believe it because I thought if the processor was bad, the behavior would be more consistent with respect to trying to boot on the mac side.
     

Share This Page