HELP: Kext issues with wifi dongle

Discussion in 'PowerPC Macs' started by KawaiiAurora, Dec 24, 2016.

  1. KawaiiAurora macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #1
    Hey,
    I have a Sawtooth G4 @ 400MHz with fresh install of OS X 10.4 (8A48). Now, I have a Dynamode WL-700N-RXS which is essentially an RT2870.

    Now, I've tried installing the RT2870 drivers for OS X 10.4 from this site: https://www.wireless-driver.com/ralink-wireless-macos-drivers-software/

    They install just fine BUT there's one issue. The dongle isn't recognised by the utility..
    Now, I've done a kext modification and changed one entry in the plist file to the device and vendor ID of my device but it's still not found.. (even after rebooting and the kext is installed properly as it shows up in kextstat)

    Vendor ID: 0x148f (Decimal = 5263)
    Product ID: 0x7601(Decimal = 30209)

    The dongle fully works as I'm currently using it on a Windows machine with RT2870 drivers installed. The USB ports on the Sawtooth also works well AFAIK.

    What I get from the system log:
    AppleUSBOHCI::Found a transaction which hasn't moved in 5 seconds on bus 8/9, timing out!


    If anyone has a solution or suggest please reply!

    Section I edited:
    <key>ASUS1</key>
    <dict>
    <key>CFBundleIdentifier</key>
    <string>com.Ralink.driver.RT2870USBWirelessDriver</string>
    <key>IOClass</key>
    <string>RT2870USBWirelessDriver</string>
    <key>IOProviderClass</key>
    <string>IOUSBDevice</string>
    <key>idProduct</key>
    <integer>30209</integer>
    <key>idVendor</key>
    <integer>5263</integer>
    </dict>


    Thanks,
    Aurora
     
  2. Czo macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Debrecen, Hungary
    #2
    You have a MediaTek 7601U. That device don't work with the Ralink 28xx driver.
     

Share This Page