HELP: Linux Live-DVD killed my iMac -> solved. Alu keyboard to blame

Discussion in 'Mac Basics and Help' started by swagi, Jan 19, 2008.

  1. swagi macrumors 6502a

    Joined:
    Sep 6, 2007
    #1
    Argh...I was messing around with Sabayon Linux 3.4f on my Intel Core Duo iMac (first iteration). I tried installing in Parallels, and it failed miserably. Given the fact that I used a Live DVD, I just went on, popped the DVD in and booted from it.

    The Live DVD started and then hung during boot process. I had a grey screen and the all too common Linux cross depicting the mouse.

    After waiting I tried to restart. The iMac would just boot from the DVD.

    I was googling a little for a way to force eject a DVD (things like pressing the mouse button just wouldn't work) I realized, that I don't have an Apple Logo on startup anymore. I managed to get the DVD out by pressing it down with a credit card thingy, so it couldn't spin (something I found in a Mac forum).

    Then I inserted the iMac restore DVD, that came with my Mac. Still no Apple logo and I get a black screen with "No bootable Disk - insert boot disk and press any key".

    I burnt a Firmware restoration CD. Also inserting this CD will result in the same strange error.

    Keyboard shortcuts won't work. It seems like the iMac doesn't recognize any keys. Maybe that's due to the fact, that I bought a new Apple keyboard for it (the Alu one).

    Who can help???

    P.S.: The last time I mess around with Linux for sure :mad:
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    sorry for your loss

    did you try boot your iMac without any disk in the driver?
     
  3. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #3
    Without knowing more details, you may want to try this

    Boot you mac into single user mode:
    On Boot, hold down the CMD +s keys

    And run type this at the command prompt:
    fsck -y
    This will do a file system scan and repair any permission issues you maybe having.

    Once it is done, you can just issue a reboot command and restart your Mac

    I somehow don't think it was the live linux CD/DVD that you were using that caused the problem. I have run linux on my MBP and iBooks without any issues and yes, that Sabyon linux disk was one of them.
     
  4. swagi thread starter macrumors 6502a

    Joined:
    Sep 6, 2007
    #4
    Yes, tried that. I also tried nearly every keyboard shortcut, that's documented. My guess is that either the Linux Live DVD destroyed the USB driver or the Alu keyboard uses other signals than the standard white one (which I killed with coffee btw. ;) ).

    I was hoping for target disk mode, but even that won't work.

    Strange thing is, that the chime is gone, the Apple is gone.

    Only thing that really worked, was holding the power button. I then receive a blinking status light and a long bleep. But even that brings me back to the black screen with 'No bootable disk'

    So, while I'm ruining my slot-loading drive with an old cplatic card (and getting pissed as hell at Apple for leaving out a force eject button), I'm curently in the process of torrenting a mini-distro of Sabayon. Maybe I can get that CD to start and maybe (with a little luck) I can get hold of my Mac again.

    It's just so crazy. I feel like a Live-DVD killed my Firmware and I have yet to find a way to get it back on. I'm perfectly okay with the lost data (well, I'm not, but call it resignation), but I want to put Mac OS X back on my Mac.
     
  5. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #5
    Insert your Apple restore CD, restart and immediatly hold down the C key. That should boot from the CD and all will be well again. A live CD will not screw up your computer unless you do something stupid.
     
  6. swagi thread starter macrumors 6502a

    Joined:
    Sep 6, 2007
    #6
    Thanx for your help. I tried, and I even don't get into single user mode.

    Currently I think it's the keyboard's fault. I will exchange the Alu one against another white one (luckily I have access to four iMacs :D ). Maybe I'm lucky with that.

    But I really appreciate your input.
     
  7. swagi thread starter macrumors 6502a

    Joined:
    Sep 6, 2007
    #7
    Problem Solved

    :D:D:D:D

    So, coming back from my little shopping trip, I plugged in a standard white keyboard, that came with my iMac.

    Guess what: Suddenly holding the option key on startup worked for me.

    So I guess it's time to clearly say: I'm sorry for my Linux rant. It definitely is a problem with the aluminium keyboard.

    And now I'm even more majorly pissed off by Apple. Why the hell did they have to break something, that's working.

    Is there a Firmware update I have to apply, to use the Aluminium from the beginning?

    So in case any of you still have a white iMac, test out, if you can reproduce this bug. Plug in an Alu keyboard and try to access the keyboard shortcuts in the beginning. In my case, they won't work.

    As soon as I connect the standard white keyboard everything is fine. Currently I'm doing an fsck -f in Open firmware (went well). Now I'm performing a Hardware Test off the Leopard CD.

    I really thank you guys for your help. So a warning to all of you:

    Keep a standard white keyboard for your white iMac! :mad::mad::mad:

    So, and now back to Sabayon. Maybe it will work out better with the white keyboard :D
     
  8. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #8
    i dont know, its a keyboard. ......sigh.....most straight forward part of a computer.......maybe not....
     
  9. GroovyLinuxGuy macrumors regular

    GroovyLinuxGuy

    Joined:
    Apr 2, 2006
    Location:
    Canada
    #9
    Glad to hear it all worked out in the end. I bought one of the alu keyboards for my MBP and love it...will have to keep this in mind if I run into any issues though.

    Cheers!
     

Share This Page