Help! Lion won't let me open multiple selected files!

Discussion in 'Mac OS X Lion (10.7)' started by zoeofdoom, Feb 27, 2012.

  1. zoeofdoom macrumors newbie

    Feb 27, 2012
    It's really hard to check and see if anyone's asked this before, because my issue is too similar to the "resume" feature. It's basically the opposite, though.

    When I select multiple documents and try to open them in Word/Office, only 1 to 3 of the files open. :confused: I regularly open 20-30 files at a time, in order to close them as I finish working on them, so opening each one by hand is becoming a bit of a pain!

    If nothing else, opening multiple documents simultaneously has always worked before in every other version of MacOS. I've tried selecting them all and dragging them to the Word icon on the Dock, tried selecting all and hitting enter, opening the folder and using the menu to "select all" and then "open"...nothing doing. It's strangest to me that it's random how many files will open, though it's never more than 3 at a time. Known bug? "User Feature"? Help!


    Oh, and, this is on a brand new Mini, running Office 2008. I have this problem with opening multiple images at once also, though it seems more random and is willing to open more files into preview (2-5 instead of 1-3). WTH. The files are almost always freshly downloaded one-by-one, but I don't get any nasty nag screens telling me I'm about to open a file downloaded from the internet, so it isn't THAT problem.
  2. GGJstudios macrumors Westmere


    May 16, 2008
    I routinely open a dozen or more Excel files simultaneously. I just select them, right-click and select "Open". I can't tell from your post if you're doing something different, but it sure works fine for me.
    ScreenCap 1.PNG
  3. zoeofdoom thread starter macrumors newbie

    Feb 27, 2012
    That's what I've always done too. It just won't open ALL the stupid things I've selected, only 3 or so.
  4. GGJstudios macrumors Westmere


    May 16, 2008
    Strange! It sounds simple, but have you tried restarting your computer? Have you opened each one to make sure nothing is wrong with any of the documents?
  5. tootall macrumors regular

    Apr 17, 2011
    Quebec, Canada
  6. GGJstudios macrumors Westmere


    May 16, 2008
    Apparently, the problem isn't selecting them, but having them open, once selected.
  7. CBass187 macrumors newbie

    Mar 1, 2012
    Same issue here

    @Zoeofdoom - have you noticed that the issue is ONLY with .docx files? I can open .doc files just fine in batches of 4,5 or 6, but I can't even open up 2 .docx files at the same time.

    I can select multiple files at once, then when I go to open them by:

    - right clicking and selecting open
    - right clicking and selecting open-with
    -dragging and dropping all the files into Word

    it only opens one of the files.

    I too have Lion OS and really wish I hadn't upgraded now. :-/
  8. dhd macrumors member


    Dec 12, 2007
    I just select the files I need to open and hit Command + O.
  9. asg0321 macrumors newbie

    Nov 16, 2012
    Same thing

    I have the exact same problem. I select multiple .xlsx files and try open them at once, but it only opens one or two :(
  10. Skyron macrumors newbie

    Jan 25, 2013
    Same problem--Lion can't open multiple .docx docs

    This is really frustrating. Why has Apple not addressed this problem in over a year. I cannot open more than a single .docx document at a time no matter which of 5 different methods I use to open the files! This is not a problem for other files, such as PDFs.

    Has anyone on this list figured out a work-around?
  11. Nam Pla macrumors member

    Jun 7, 2009
    Just a wild guess here, I don't use Word or MS Office stuff. But maybe it's a Word or MS issue? Or compatibility with OS X issue? I regularly open several files in NeoOffice without a problem.

    A search of Apple's discussion forums may get you more info and/or a possible fix or explanation.
  12. MisterMe macrumors G4


    Jul 17, 2002
    Apple has refused to address this problem because there is no problem for Apple to address. Before writing this post, I selected ten Word .docx files and opened them simultaneously. This worked fine using Word 2011 in OS X 10.8.2
  13. sancalisto macrumors newbie

    Feb 26, 2013
    Same problem

    MisterMe, it's wonderful that it works for you. However, you can't say "there is no problem for Apple to address" when several people--and now I am adding my own voice--have said there is a problem.

    Like you, I am using Word 2011 in OSX 10.8.2. This is what happens whenever I select all files in a folder and select Open:

    If a folder contains all .doc files, they all open.
    If a folder contains mixed .doc and .docx files, all the .doc files open but only the first .docx file opens.
    If a folder contains all .docx files, only the first file opens.

    Therefore, there is definitely a problem.
  14. talmy macrumors 601


    Oct 26, 2009
    There is a problem, but it isn't with the OS. I changed the default application for docx files and tried opening up six at once. It worked for TextEdit, Pages,, and NeoOffice. It failed for LibreOffice and Microsoft Word 2011 and 2008. The problem lies with Microsoft and The Document Foundation. Of course The Document Foundation might just be mimicking the functionality of Microsoft Word :). Apple's coding is fine.
  15. c6wooden macrumors newbie

    Aug 27, 2013
    I know this is an old thread but I have the same problem.
    The only workaround I have found is to close Excel, then drag my group of selected files to the Excel icon in the dock (or right click->open). This will open them all.
    The trick is to have the program closed. Once it's opened, it's back to only opening one at a time.

Share This Page