Help! Lost 80% of my fonts and can't install new ones

Discussion in 'iMac' started by alex.debirk, Mar 2, 2013.

  1. alex.debirk macrumors newbie

    Joined:
    Mar 2, 2013
    #1
    I have a strange problem with fonts that I can't seem to find any help for in existing threads around the internet.

    I have a 2009 24" iMac that is running Mountain Lion. I have two accounts on the machine: one for me and one for my wife.

    On both accounts, There are a lot of fonts that have been added to the original ones that came with the machine. However, on my account only, no program will access these fonts suddenly. They are there in the Library's Fonts folder and not in the disabled fonts folder. Font Book also says they are installed. I also can't install any additional fonts--no program (word, Photoshop, etc.) will "see" them after I do. I can still access these fonts and install new ones on my wife's account no problem. So why in the world can I not do it in my account? I've tried doing atsutil databases -removeUser in Terminal, I've tried deleting the Adobe Font caches as well as the Mac HD Font Cache. Nothing works.

    *sigh* I've never had more unstable machines than my Mac computers. I thought Macs were supposed to be the stable ones.
     
  2. one1 macrumors 65816

    Joined:
    Jun 17, 2007
    Location:
    Chattanooga, TN
    #2
    Why blame the mac for something you did? You need to clean the disk up by going to disk utilities and repair permissions. You are installing system wide fonts for individual users, of course it's going to be an issue unless you repair disk permissions. Good luck!
     
  3. alex.debirk thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #3
    Thanks for the suggestion. Permissions repair fixed a lot of problems that I wasn't aware of, but not the font issue. I've since moved all of the fonts from my user fonts to the system fonts, and I checked that they work in my wife's account. Any other ideas?

    And sorry for the dig on Macs. I should specifiy what I mean, and why it makes me lose confidence in Apple computers. This problem didn't happen immediately after I installed a font or anything. It seems to have occurred spontaneously some time in the last few months, during which I didn't use the computer to do more than check my email maybe once every few weeks. I would call that unstable behavior. And if installing system wide fonts to a user account will cause problems down the line, why is Font Book's default configuration set up to do that? If following apple's online instructions to do something through its own program on default settings causes a meltdown somewhere down the line, how is that my fault? How would I know that it's a problem? And what other default programs are laying time-bombs? Do you see why it makes me wary?

    Anyway, thanks for the help--any other suggestions would be appreciated.
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    There is no Disabled Fonts folder in OS X. You must have created one, which suggests that you're doing non-standard things. You don't need to put fonts in a separate folder. You can manage them from FontBook. That's the whole point of the app.

    Put all your fonts in /Library/Fonts, and each user can have different sets active in their accounts.

    It's hard to say what might have gone wrong without delving deeply into file attributes of particular files and other matters. However, fonts on OS X normally behave without such problems, so I suspect it's something that you have done that may not be optimal.

    If you have a LOT of fonts and need more sophisticated font management, then I would recommend Linotype's FontExplorerX.

    There is no need to be wary: OS X does not normally lay "time-bombs". However, it's important to find out how it's all supposed to work and follow that.
     
  5. alex.debirk thread starter macrumors newbie

    Joined:
    Mar 2, 2013
    #5
    Thanks for the help benwiggy. I disagree with most of what you said, though. I never created the Fonts Disabled folder. And both accounts have one, and other threads on the internet refer to this folder, so I'm thinking that OS X does have a Fonts Disabled folder by itself. I also installed each font by double clicking the .ttf files and when Font Book came up, clicking "Install Font." If that's not the standard operation, then Apple shouldn't have made the non-standard way the obvious way.

    Also, I would prefer not to have individual user fonts. It's really a pain when multiple people want the same font, and there's really no need to have a customized user list.

    The main issue I have with this problem is that it simply happened spontaneously. One day fonts are there, one day they're not without any active manipulation from me. Maybe it was something I did, but whatever it was, it happened a long time before the problem occurred. The problem is probably deeply rooted in the murky labyrinths of the hidden files, something impossible to find or trace. Is there a "clean slate" kind of thing that I can do to just start from square one and bring the fonts back in?
     
  6. Nuke61, Mar 5, 2013
    Last edited: Mar 5, 2013

    Nuke61 macrumors 6502

    Joined:
    Jan 18, 2013
    Location:
    Columbia, SC
    #6
    Have you checked the permissions of the fonts that applications can't use to see if your user account has read/write permission? Compare the permissions for fonts in your wife's login vs yours.

    Here's an in-depth article about Mac font system, but to me it sounds like a permissions issue. http://www.jklstudios.com/misc/osxfonts.html
     

Share This Page