[HELP] Lost Mac Partition

Discussion in 'Windows, Linux & Others on the Mac' started by initialshl, Dec 14, 2011.

  1. initialshl, Dec 14, 2011
    Last edited: Dec 14, 2011

    initialshl macrumors newbie

    Joined:
    Jul 10, 2010
    #1
    Hi, I ran into some problems while trying to expand my boot camp partition.
    It wasn't successful, and brought me more problems instead.
    I hope that you guys can help me out.

    First, I booted into my Mac Snow Leopard, and shrunk my mac partition.
    I then booted in my Windows 7 using Boot Camp 3.3, and messed around
    with disk management tool, diskpart in elevated command prompt, and
    EASEUS partition manager.

    I created a new partition (NTFS) in windows 7 disk management tool
    in the unallocated space, messed around trying to merge with
    my Boot Camp partition, and deleted it.

    I tried to extend my Boot Camp partition using EASEUS partition manager,
    but it gave me an error and restored my things.

    My Mac partition shows as a separate unallocated space from the
    real unallocated space.

    I created a new partition in the unallocated space using EASEUS,
    and tried to merge them. It didn't work, so I deleted the new partition,
    and the unallocated space seems to have merged with my Mac partition!

    I ended up with these:
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    So now my Mac OS X is missing, and I do not know how to get it back.
    If I try to reboot into my Mac OS X, it will be the grey screen,
    but no Apple or loading gear, it will boot into Windows 7 after a while.

    The files in my Mac Partition (E: drive) are still intact,
    so I hope that someone can guide me to boot into Mac OS X again.

    Thanks!

    P.S. Those screenshots above shows what I have now...
     
  2. initialshl thread starter macrumors newbie

    Joined:
    Jul 10, 2010
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Bump, help me pls
     

Share This Page