Help! Lost the dock, Disk Utility won't open, and I can't drag items

Discussion in 'MacBook' started by Kelly1432, Sep 15, 2009.

  1. Kelly1432 macrumors newbie

    Joined:
    Sep 15, 2009
    #1
    This is gonna be kinda long! sorry!

    First I updated my iTunes so that I could download a video because it said I needed to. After it downloaded, it said that I had to update Safari to access the iTunes store. I tried to update Safari, but then it said I had to do a Security update. So, I went ahead and tried to update it...Right when it's almost done uploading, it says that there was an error. I tried to update it at least 4 times. I thought, "Okay, I'll do this later" so I turned off my computer. When I turned it on, I put my mouse on the bottom to make the dock appear but it didn't! I tried everything but nothing is working to make it come back! Then I tried to open the Disk Utility but it won't...And lastly, I can't drag items! For instance, if I want to save a pic on my desktop, it won't let me drag it to the desktop. Oh yeah...it won't let me minimize anything, either :(

    PLEASE! If anyone can help me fix this I will greatly appreciate it!
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    Did you boot from your Mac OSX install disk and use that Disk Utility? Repair Permissions with that and see if it makes a difference. And do you have a Time Machine backup?
     
  3. Kelly1432 thread starter macrumors newbie

    Joined:
    Sep 15, 2009
    #3
    lol..i have no idea what you just said. but i can tell you that when i click on disk utility it won't open. it does that thing where it shoots out but it doesn't actually open. i don't think i have a time machine backup. do u have anymore suggestions?:eek:
     
  4. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #4
    Well do you have the disk that came with your Mac?
     
  5. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #5
    First try a simple reboot/PRAM reset

    Maybe your HDD file system is corrupted reboot your mac hold down cmd+s till you see single mode (CLI)

    Then type /sbin/fsck -fy

    if it sees error it'll repair it, if not then, type reboot and then bust out the system restore disks...you might just have to reinstall OS X
     
  6. Kelly1432 thread starter macrumors newbie

    Joined:
    Sep 15, 2009
    #6
    Okay, so I rebooted and typed /sbin/fsck -fy. It said the count of everything (ex: leaf record count should be 1121847 instead of 1121848).

    When everything was done it said:

    ****File System was Modified****
    localhost:/ root# Sep 17 20:14:01 launchd: Bug: launchd. c: 492:30:
    chown (ourdir, getuid (), getuid()), ! : -1 Sep 17 20:14:01 launchd: Bug: launchd. c: 492:30:
    chown (ourdir, getuid (), getuid()), ! : -1

    Then it stopped after that so I just turned it off by holding the power button. I turned it back on and it's still the same---no dock, can't drag items, etc.

    Was I supposed to do something else after it said File System was modified? I don't know if I have the restore disks, but I'll try those later if I find them.

    BTW, thanks SHADO and daneoni for trying to help me...I really appreciate it :)
     
  7. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #7
    Can you get to System Preferences from the Apple menu?

    Maybe try making a new admin user and logging in with that to see if it's system-wide or isolated to your original account.
     
  8. KielderWolf macrumors regular

    KielderWolf

    Joined:
    Aug 1, 2009
    Location:
    Northeast England
    #8
    You could try foxing it back into showing the Dock through the Terminal. Hit cmd+space and type in Terminal, highlight it and hit Enter to launch it, then type this exactly:
    Code:
    killall Dock
    This may trick the computer into loading it after it thinks the process has shut down. It has worked for me in the past when the Dock has gotten stuck.
     
  9. Kelly1432 thread starter macrumors newbie

    Joined:
    Sep 15, 2009
    #9
    i tried that already and nothing happened:(. i'm just gonna try and reinstall mac os x. thanks, though :)
     
  10. flatfoot macrumors 65816

    Joined:
    Aug 11, 2009
    #10
    Hi Kelly1432,

    I once had similar problems with my MacBook.
    It turned out the hard drive was full. Freed a few gigs and everything was fine again!
     
  11. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #11
    Well it would have been preferable if you just typed reboot and pressed enter rather than forcing a shutdown but no matter.

    Another thing you can try is to trash (dont empty the trash yet though) your Dock, Disk Utility & Finder (com.apple.Finder.plist, com.apple.DiskUtility.plist, com.apple.dock.plist & com.apple.dock.db) preference files. It's found in /Home/Library/Preferences then reboot your computer. It should regenerate new plist files for you and hopefully solve your issues. If it does the former or both then you can empty your trash.

    Try it out if you haven't restored already
     
  12. Kelly1432 thread starter macrumors newbie

    Joined:
    Sep 15, 2009
    #12
    Hey guys...

    I don't know what else to do. I'm sooo bummed cuz nothing is working.

    I tried the discs to install but they won't even read. It says "You cannot open the application "Install Mac OS X and Bundled Software" because it may be damaged or incomplete."

    daneoni, I don't want to trash the Dock, Disk Utility, or Finder cuz I'm afraid that I won't be able to restore those if it doesn't work...

    Oh! I just thought of something...what if I download my original Mac OS X update? Like, go to the apple website, look for a Mac OS X 10.4.7 update and then download it? Do you guys think that will work?

    Do you guys have any more suggestions? Or should I just take it to get fixed if the update doesn't work?
     
  13. Jasoco macrumors 6502

    Joined:
    May 28, 2006
    #13
    Did you reboot with C held down? Instead of inserting the disc and double-clicking the Install icon?
    Put the disc in and reboot. After the chime, hold C until something comes on screen and you hear the disc being read.
     
  14. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #14
    You're not trashing the apps just their preference files which can get corrupted and i did tell you how to restore them IF (...and this is highly unlikely) new ones weren't generated but its your call

    Also don't try to install Mac OS X from the desktop boot from the CD instead
     
  15. drseuss macrumors newbie

    Joined:
    Oct 6, 2009
    #15
    I have the same problem

    I was also asked to install the Security update for Safari to work and there was an error, now I don't know what to do. I've tried everything suggested apart from re-installing from the cd. Did you get it working in the end?

    I've had to re-install once before and I lost some of my software that had been installed ages ago and I didn't have the disks for them as I lost them in a move, so I'm worried it'll happen again and I can't afford to any again :(

    Please let me know.
     
  16. Kelly1432 thread starter macrumors newbie

    Joined:
    Sep 15, 2009
    #16
    hey drseuss...no, it's still not working. i tried everything they suggested but nothing worked so my only option is to take it to get fixed.
     

Share This Page