HELP - Mac Pro stuck in Windows Install Cycle

Discussion in 'Mac Pro' started by Melbourne Park, Sep 14, 2012.

  1. Melbourne Park, Sep 14, 2012
    Last edited: Sep 14, 2012

    Melbourne Park macrumors regular

    Joined:
    Mar 5, 2012
    #1
    My MacPro 2010 is stuck trying to install Windows.

    It has an SSD Intel 520 that is its boot drive.

    It has the factory 1TB drive with the factory OS on it (cloned with super duper that drive OS to the SSD to make the SSD the boot drive. The SSD hangs off the spare DVD drive cabling)

    It has a 2TB drive with some photo files on it (intended for backup, but not setup yet).

    There is a Snow Leopard on a USB drive, and a Leopard on a firewire drive (but no suitable cable for the Mac Pros different Firewire connection).


    The problem: there is a Windows 7 disc in the disck drive; the computer will not VRAM reset, and it boots into the Windows install DVD, but it will not installl onto the 100GB partition that bootcamp just setup.

    I cannot remove the Windows disc.

    I cannot engage the expected bootcamp OS choice window by pushing the option key on startup.

    I cannot zap any RMA via option/command/P/R key selections.

    I cannot get a OS X start up via the shift key engagement on startup.

    I tried leaving my finger on the startup button, and the machine did ring tone and restart, but nothing changed.

    I removed the plugs for the DVD drive - no difference, a bootcamp windows startup commenced, but then hung as no Windows disk was found.

    I tried disconnecting all the drives and bootiing off the external - but a folder flashed on and off, indicated the OS could be found, but for no apparant reason, it was not being allowed to boot that Snow Leopard OS.

    I tried just having he 1 GB disk installed, but once again, it went to an early black and white PC start up sequence.

    On going forward with the Windows install, Windows will not install into the 100GB Bootcamp partition on the 1GB drive. I then allowed it to refort that partition to NTSC, but it made no difference

    I've tried with just the 1TB drive connected, but the same problem exists.

    If I could manually remove the Windows disk from the DVD drive, then maybe I could put a snow leopard disk into the drive, and get the mac to boot from it. But ... it would not do that, because the machine is dominated by a crazy Windows install ... but if I disconnected all the drives, then removed the Windows disk (somehow???), then put in the Snow Leopard disk, then perhaps I could command the computer to install from the external USB Snow Leopard system.

    I fell like putting the MacPro in a full bath and turning it on ... I'd appreciate some advise.
     
  2. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #2
    Hold down left mouse or total mouse buttons at boot chime depending on the mouse you are using. Also make sure it is USB mouse. Otherwise you can boot into single user mode. Boot holding cmmd-s at startup. Then follow the prompts for mounting the filesystem. If memory serves me it is:

    /sbin/mount -uw /

    Then use this command:
    drutil eject

    You can also list the disks and Discs with:
    diskutil list

    If none of these work you can get a paperclip and right at boot stick it into the release button hole at exactly the right time and that has worked as well.
     
  3. Tucom macrumors 65816

    Tucom

    Joined:
    Jul 29, 2006
    #3
    Try holding down Option the whole time after boot chime, and this should allow you to select the OS.


    Or hold down C as it's booting up, and this will eject whatever media is in the drive.



    Keep us posted :)
     
  4. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #4
    Holding 'c' down forces it to boot from the media not eject it. Option has been tried by the OP and does not work for their situation unfortunately.

    "I cannot engage the expected bootcamp OS choice window by pushing the option key on startup."
     
  5. Tucom macrumors 65816

    Tucom

    Joined:
    Jul 29, 2006
    #5
    I thought it was spacebar that booted, and I say C because I just had the OP's issue myself kind of. It kept wanting to install Windows (when I was trying to install Win 7 64bit) from my Boot Camp selection, and wouldn't eject the install DVD until I held down C.


    I could be wrong though...
     
  6. minifridge1138 macrumors 6502a

    Joined:
    Jun 26, 2010
    #6
    To the Original Poster,

    What do you want to do?

    Get the computer to boot normally or get windows install for bootcamp?
     
  7. Melbourne Park thread starter macrumors regular

    Joined:
    Mar 5, 2012
    #7
    This issue started with trying to install Windows. But Windows will not install onto the partition which Bootcamp created - 100GB.

    So, I want to boot normally into Mac OS X, and then I'll try again with using a smaller partition - perhaos 32GB.

    I also want to check the 2GB drive's photo files, and ensure they are safely on the 1GB drive. When I know that, I'll engage time machine onto the 2GB drive.

    Then, I may clone a system to an external drive.

    And then - I'll try to install Windows again.

    Right now, the machine seems trapped into a Windows install mode, and refuses to operate as a Mac, no matter what key sequences I perform.

    I am using a USB Mac keyboard, but a contemporary radio super mouse. I will try a Mac USB mouse - but I doubts its an issue.

    I cannot get a VRAM re-set, which seems very strange. I guess because its not a Windows command.
     
  8. Melbourne Park thread starter macrumors regular

    Joined:
    Mar 5, 2012
    #8
    Tried pressing down a USB Mac Mouse on startup. Did not reject the Windoze disc. Then switched over to the install Win screen again ....

    Now talking to Apple, who are as bemused as I am.

    Queried my about the SSD ... an Intel 520 240 GB ... I queried them about not shipping an OS disc with the machine. Or a USB stick with an OS on it (sure Hackintosh's have stopped Apple selling that). Same with the discs.

    But I have a Snow Leopard disc ... as well ans a external hard drive with Snow Leopard on it ...
     
  9. El Awesome macrumors 6502

    El Awesome

    Joined:
    Jul 21, 2012
    Location:
    Zurich
    #9
    Have you tried getting into your Mac via Target Disk Mode?

    Or simply disconnect the DVD drive. That should be the easiest option.

    And just to make sure: You know that you have to format the partition the BootCamp manager created. You need NTFS format which OS X can't handle. Choose it in the installer and select "Format.." in the menu bar further down. You did that step, right?
     
  10. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #10
    :D

    ...Weird icon issues today.
     
  11. El Awesome macrumors 6502

    El Awesome

    Joined:
    Jul 21, 2012
    Location:
    Zurich
    #11
    Worth a try, isn't it?
     
  12. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #12
    Totally. It was incredibly obvious. No one mentioned it after a bunch of complicated work arounds. I love it.
     
  13. Melbourne Park thread starter macrumors regular

    Joined:
    Mar 5, 2012
    #13
    Found out what the problem was

    Guys - I ended up disconnecting all the drives, and trying to boot from an external USB disk with Snow Leopard on it. I had booted from that disk before, but this time, it would not boot. That was with no internal drives connected at all.

    As far as the failure for the option key to function - I don't know ... I had the keyboard connected through an Eizo monitor, which has lots of electronics in it. I had thought I had removed it and straight connected it. I recall doing that ...

    Perhaps I did not ... because it opened at the Genius Bar, no problems. They checked the machine, it passed all hardware tests. Hmmm

    Why wouldn't Windows install? I took it home, and this time, I wanted to ensure I had good back-up, via Time Machine being enabled. I had a 2TB drive there, for that purpose. But I had some important graphic files on it, so I wanted to drag those across to the 1TB drive, which was where I was putting the BootCamp drive for Windows.

    When copying, I had to type in permissions ... I changed some of those - which took lots of time - and then it happened again, with me having to type in my log-on password. I rang Apple (second time on that issue), and they said check permissions.

    It was permissions. I must have imported from my old computer (which had a flakey drive and I was often repairing permissions on it) corrupt permissions. Those corrupt permissions stopped Windows installing on the bootcamp partition - despite me formatting the drive to NTSC under Windows. I could not boot from the external USB drive for the same reason.

    So ... before installing Windows, due a whole disk check yourself, and check and repair your permissions. Also when setting up a new computer and importing all your data and setting from an old computer via Firewire etc for from a boot drive from your old computer - after doing so, repair your permissions. Because any permission errors may well come across, and cause un-predicatable results.

    Thanks for the help guys.
     

Share This Page