help mac/safari

Discussion in 'MacBook Pro' started by boateng, Aug 11, 2013.

  1. boateng macrumors 6502

    Joined:
    Sep 8, 2012
    #1
    Basically this has been happening with my macbook pro for a a long time

    Whenever i turn my mac on and go on safari, as soon as i start typing up a web page on safari, a spinning wheel appears and safari freezes for like 20-30 seconds...and then the spinning wheel cursor disappears...

    is there something wrong with my mac? this only happens when i turn the mac on and go on safari.
     
  2. robvas macrumors 68020

    Joined:
    Mar 29, 2009
    Location:
    USA
    #2
    Clear your cache and history
    Remove any extensions or add-ons to Safari
     
  3. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #3
    how do you do this?

    also if i clear my cache history wont i lose all my saved passwords on websites etc...?
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    No, clearing cache and history doesn't remove saved passwords. You can go to Safari > Preferences > Extensions and turn them off, to see if it makes a difference in performance. If it does, turn them back on, one at a time, until you find the culprit.
     
  5. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #5
    oh i see

    the thing is my performance isnt really effected. this only happens once i boot the computer up and go on safar for the 1st time then that spin wheel things occurs. after that it doesnt occur anymore...

    any idea what to do? i am worried my laptop may be broken:eek:
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    No, that's certainly not an indication that your Mac may be broken in any way. There are any number of reasons why that may be happening. If it only happens infrequently, I certainly wouldn't waste time worrying about it. If your performance is always or frequently being affected, then it would merit more attention.

    If you're having performance issues, this may help:
     
  7. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #7
    Hmm like i said this spinning wheel things only occurs when i start up the mac and go on safari for the firs time and type something. This happens for like 20 seconds where safari freezes, then it works again...

    I don't know what to do:mad:
     
  8. b06tmm macrumors regular

    b06tmm

    Joined:
    Jul 23, 2009
    Location:
    South Louisiana
    #8
    How about waiting 60 seconds or more before you launch Safari. Does it still happen?
     
  9. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #9
    i have tried that...it still happens, that spinning wheel occurs when i try and type something on safari for like 20 seconds and then safari freezes then its fine
    it happens everytime but google chrome seems to be okay

    not sure if i should go to apple?
     
  10. dastinger macrumors 6502a

    dastinger

    Joined:
    Mar 18, 2012
    #10
    Have you done what was advised here? Regarding history, cache and extensions?
     
  11. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #11
    i dont get how to do the extensions...?

    also cache will delete all my passwords right?
     
  12. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    Safari > Preferences > Extensions
    I already answered that in post #4.
     
  13. boateng thread starter macrumors 6502

    Joined:
    Sep 8, 2012
    #13
    hey

    sorry for the late reply

    regarding the extensions....i just checked mine on my mac and its empty. i dont have any....if that is the case then why does safari is always do that when i start it up:eek::confused:
     
  14. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #14
    What do you have your start page / homepage set to in the General tab of Safari preferences? Could it be that that page is bogging things down? Try setting the homepage to http://www.google.com/ and see if you still have the same issue.
     

Share This Page